Won't find kernel images at boot

I have trouble booting from regular images.

(Probably) GRUB shows me this messages:
(translated by me)

Error: Archive »/@boot/vmlinuz-6.8-x86_64« not found.
Error: You must load the kernel first.
Press any key to continue …
Both default and alternative entries were unable to boot.
Press any key to continue …

Luckily, I can boot from timeshift snapshots, however they are different, older ones than what I see in the timeshift UI.

The cause, I assume, was an interupted update, where my disk space ran out during the installation step. I tried

  • pacman -Syu,
  • mhwd-kernel -i linux68,
  • mkinitcpio -p linux68

All these seem to work well, only the pacman grub hook also shows those other snapshots, I see during bootup and not the ones I am actually creating (which I can see in the timeshift UI). However, booting leads to the same error.

Also, mkinitcpio warns about
/usr/bin/grub-probe: Warning: unknown device type nvme0n1

Anyone can make sense of this?

Were these done in a chroot environment? manjaro-chroot -a

I assume you mean “won’t find timeshift image” …? :wink:

1 Like

No, I just used the timeshift snapshot, I was in. I will try it in a chroot, once I find my usb key…
As a matter of fact, it will find (some) timeshift images, what it doesn’t find are the regular kernel images in /boot (which exist).

Because of btrfs, manjaro-chroot -a does not work as one would wish.
So I had to log in via an usb-key with Manjaro on it, and (as root)
mount -o subvol=@ /dev/nvme0n1p2 /mnt, then
manjaro-chroot \mnt, then
pacman -Syu linux68
this re-installs the kernel and on the next boot up, it was detected.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.