Wireless issue - data transfer freezes while still connected


Thanks in advance for helping

Noob here, just switching from windows 7 to Linux after playing for a while with VM. So I just made a fresh install in my real hardware and before I was able to complete all the updates I got an strange behavior from my internet connection. I have no issue at all while using windows but with Manjaro my connection is stopping transferring data, besides I still remain connected. If I disconnect and reconnect, the data transfer backs to work again for a certain amount of time and stops.

The only think I tried was to change the repo mirror from standard to Brazil one, the transfer speed improves but the issue still remains.

I installed the Manjaro 20.2.1 KDE
The internet connection is trough USB Wireless adapter TP-Link TL-WN821N V.2
This device was recognized by the kernel as:
Qualcomm Atheros Communications TP-Link TL-WN821N v2 / TL-WN822N v1 802.11n [Atheros AR9170]

Any suggestion?

From some google searches looks like USB Wireless Adapters are a kind of nightmare on linux :sweat_smile:

I tried also to attach images but i got the message that I can’t embedded images nether links, so probably because my account is new, don’t know.

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=c2987d0a-3ccc-4056-bdcb-22de9c2fbb5f ro quiet apparmor=1 
  security=apparmor resume=UUID=87d4ac5e-e22c-413e-806a-74ff152a793e 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: Gigabyte model: GA-870A-UD3 v: x.x serial: <filter> 
  BIOS: Award v: F5 date: 08/01/2011 
  RAM: total: 7.77 GiB used: 3.31 GiB (42.6%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: AMD Phenom II X4 965 bits: 64 type: MCP arch: K10 
  family: 10 (16) model-id: 4 stepping: 3 microcode: 10000C8 L2 cache: 2 MiB 
  bogomips: 27335 
  Speed: 800 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 
  Flags: 3dnow 3dnowext 3dnowprefetch abm apic clflush cmov cmp_legacy 
  constant_tsc cpuid cr8_legacy cx16 cx8 de extapic extd_apicid fpu fxsr 
  fxsr_opt ht hw_pstate ibs lahf_lm lbrv lm mca mce misalignsse mmx mmxext 
  monitor msr mtrr nonstop_tsc nopl npt nrip_save nx osvw pae pat pdpe1gb pge 
  pni popcnt pse pse36 rdtscp rep_good sep skinit sse sse2 sse4a svm svm_lock 
  syscall tsc vme vmmcall wdt 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 01:00.0 
  chip ID: 1002:67df 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: amdgpu,ati 
  unloaded: modesetting,radeon alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: DVI-D-0 res: 1920x1080 hz: 60 dpi: 96 
  size: 510x290mm (20.1x11.4") diag: 587mm (23.1") 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.39.0 
  5.9.16-1-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.3.1 direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: Gigabyte GA-880GMA-USB3 
  driver: snd_hda_intel v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aaf0 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: 9e00 bus ID: 06:00.0 
  chip ID: 10ec:8168 
  IF: enp6s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros TP-Link TL-WN821N v2 / TL-WN822N v1 802.11n 
  [Atheros AR9170] 
  type: USB driver: carl9170 bus ID: 4-4:2 chip ID: 0cf3:1002 serial: <filter> 
  IF: wlp0s19f2u4 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No RAID data was found. 
  Local Storage: total: 335.36 GiB used: 8.56 GiB (2.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Patriot model: Burst size: 223.57 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: KB.3 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT120BX100SSD1 
  size: 111.79 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: MU01 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH22NS50 rev: TN02 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw size: 214.77 GiB size: 210.4 GiB (97.96%) used: 8.5 GiB (4.0%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: c2987d0a-3ccc-4056-bdcb-22de9c2fbb5f 
  ID-2: /home/<filter>/Games raw size: 111.79 GiB size: 109.53 GiB (97.98%) 
  used: 60 MiB (0.1%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: ssd-games 
  uuid: 49fbfc03-2923-49f0-a550-312f1f31aae3 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 87d4ac5e-e22c-413e-806a-74ff152a793e 
  Message: No Unmounted partitions found. 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 5 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 4-4:2 info: Qualcomm Atheros TP-Link TL-WN821N v2 / TL-WN822N v1 
  802.11n [Atheros AR9170] 
  type: Network driver: carl9170 interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  chip ID: 0cf3:1002 serial: <filter> 
  Hub: 5-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Hub: 6-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Hub: 7-0:1 info: Full speed (or root) Hub ports: 5 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Hub: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Hub: 9-0:1 info: Full speed (or root) Hub ports: 4 rev: 1.1 speed: 12 Mb/s 
  chip ID: 1d6b:0001 
  Device-1: 9-3:2 info: SINO WEALTH USB KEYBOARD type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  chip ID: 258a:0001 
  Device-2: 9-4:3 info: Pixart Imaging Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s 
  chip ID: 093a:2521 
  System Temperatures: cpu: 39.5 C mobo: N/A gpu: amdgpu temp: 43.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 930 
  Processes: 236 Uptime: 1h 33m wakeups: 1 Init: systemd v: 247 Compilers: 
  gcc: N/A Packages: pacman: 1249 lib: 397 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: konsole inxi: 3.2.01 

:+1: Welcome to Manjaro! :+1:

That kernel is an experimental kernel and EOL as well, so upgrade to the 5.4 LTS (Long Time Support) first and 5.10 LTS second and see if you have the issue in both of those as well and if you do, please feed back.


Hello Fabby, thank you.

I did as you suggested and with Kernel 5.4 LTS I was able to complete the update without any issue, so looks like it worked. I can say the same for the kernel 5.10 LTS.

So probably the modification in the kernel 5.9.16-1-MANJARO caused the issues.

Note: Besides the kernel 5.10 is indicates as LTS in the kernel.org from Manjaro kernel settings it’s not. See attached image.

Sory to remove the solution but the issue happened again, it just took much more time or data transfer to happen. When the internet drops now with kernel 5.10 it indicates a massage “limited connectivity”, and add the symbol “!” to wifi system-tray indication. see attachment.network13.

It just happen now after my post and after download a linux ISO for test purpose.

And 5.4? (Because 5.10 is the most recent LTS, so not as stable as 5.4)


The kernel 5.4 do not shown the massage “limited connectivity” nether the sign “!” in the system-tray but looking into the network speed history it present some instability because the data transfer freezes for short time and then back again to transfer without needs to disconnect and reconnect. I’m doing this test with torrent download because it’s easier and I can download from multiple sources to keep the speed up. the network speeds indicates basically same speed if I look from qTorrent software interface.

Sometimes this freezes happens often and sometimes it take more time to happen. a bit strange.

Note: When the transfer freezes it freezes the income and outcome as you can see from red and green lines.


The only thing I can tell you is: stay on 5.4 LTS and keep updating 5.10 LTS and try it out after an update and if it’s a bug, it’ll get resolved and then stay on 5.10 LTS.

If you want to take a more active role, you can file a bug yourself with the kernel team, but you need to be very technical to talk to people like Linus Torvalds…


Hello Fabby,

Thanks for the help, I really appreciated. From some research I made in the internet looks like Wireless stuffs are kind of nightmare for linux so I decided to fix the issue in a different and easier way, I bought an Wireless Extender with Ethernet connection witch is more friendly and stable for linux and it’s working properly now. So I can stay with the latest LTS kernel.

Pix-Link LV-WR09

wr09_2_500 wr09_3_500

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.