Wireless HP Printer Cannot be Detected in Any Way

I have installed HP printers successfully before on my computer, however I just bought a new HP LaserJet M203dw (it’s working fine through wifi both on my work PC and mom’s Mac), and I have absolutely no idea why I cannot get it to work on Linux. Here are all the things I have tried…any help would be greatly appreciated since I have spent hours on this:

  • Followed all the steps in the manjaro printing guide even using both pamac and pacman in case one of the two had an outdated version.
  • Tried adding using the hp-setup both with mDNS/Bonjour and avahi but but keep getting the following:
error: No devices found on bus: net 
error:  HPLIP cannot detect printers in your network.  This may be due to existing firewall settings blocking the required ports.
  • Since I am at home I straight up disabled the firewall only to get the same errors as above.
  • I know the printer IP so tried adding it manually both with the hplip gui and CUPS web interface only to get the same errors.

I know that the printer does indeed support wireless and is working because all other devices in the home are able to print with it. Is there anything else I can do to try and diagnose what is happening? I have spent hours looking through all related posts and cannot find anything helpful.

P.S. I tried using ping and I cannot ping the printer. What’s interesting is that I can’t ping from my PC either but I can print from it…is this some sort of indication as to what is happening?

Let’s verify things one by one, paste the output of:

  1. $ groups
  2. $ sudo systemctl status cups.service
  3. $ sudo systemctl status cups.socket
  4. $ sudo systemctl status cups.path

It does support AirPrint, although no IPP Everywhere (could be out of date, as my 4100 also listed as AirPrint only, but I print through IPP Everywhere).

No, not all printers support pinging. Mine also doesn’t support it, but I can print just fine.

1 Like