Wireless drivers disconnecting


So recently i installed Manjaro as a dual boot on my main PC. When i first installed Manjaro using the usb live environment the wifi would discover and connect flawlessly. However after booting up the install version (6.5.3-1), not only could i not connect to my wifi but i could not even find my wifi. After going back and fourth between the live and install version i discovered that the wireless modules in the live version had a path of (/usr/lib/modules/6.5.3-1-MANJARO/kernel/drivers/net/wireless/) however the wireless modules in the install version had a path of (/usr/lib/modules/6.5.3-1-MANJARO/kernel/drivers/net/wireless/intel) so i tried copying and pasting the modules (iwlwifi) to the above folder aka the same path as the live enviorment and it worked. wifi worked great for about a week.

I then booted windows to do some work and when i switched back to Manjaro the drivers stopped working and i noticed that when i run inxi -Na i get this

  Device-1: Intel Wi-Fi 6 AX200 driver: N/A modules: iwlwifi pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 07:00.0
    chip-ID: 8086:15f3 class-ID: 0200

and yet the modules still exist in both the intel and wireless folder as was my previous fix so i dont think anything updated. this only seems to happen after switching back from my dual boot. the first time it happened after giving up and coming back later it fixed itself only for it to happen again after another switch from windows to manjaro. i have tried moving to a different kernel (6.1.53-1 LTS) and the problem still exists any help would be appreciated

You aren’t the first one with this problem. Try searching around. Hint: it’s windows and dual-booting most probably.

Oh, skipped your copying and pasting around /usr… don’t do that.

TBH, i know and I’ve read hours worth of posts with no luck at all. either the post ended with no resolution or the poster didn’t provide enough info.

These are default /usr… paths on a fresh install/live environment that pertain to the issue, wym don’t do that?

Turn off fast startup.

Because you are not pacman.

1 Like

So i had fast startup disabled months and months ago due to it interfering with accessing my bios. I knew this and never considered it an option as the issue. Turns out windows re-enabled it on update. Another reason to hate windows. Thank you though.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.