Wireless Connection randomly disconnects, restart is required

System:    Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A 
       parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=8d3c71fe-2d9a-4aa7-9fd0-0de4dae0023e rw quiet 
       acpi_backlight=none apparmor=1 security=apparmor resume=UUID=012b2228-da15-4a81-861d-f61455e3e0d2 
       udev.log_priority=3 
       Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 8470p v: A1029D1102 serial: <filter> Chassis: type: 10 
       serial: <filter> 
       Mobo: Hewlett-Packard model: 179B v: KBC Version 42.38 serial: <filter> UEFI: Hewlett-Packard v: 68ICF Ver. F.74 
       date: 04/11/2019 
Battery:   ID-1: BAT0 charge: 19.1 Wh condition: 46.7/46.7 Wh (100%) volts: 12.3/11.1 model: Hewlett-Packard Primary 
       type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge family: 6 model-id: 3A (58) 
       stepping: 9 microcode: 21 L2 cache: 3072 KiB 
       flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20760 
       Speed: 1197 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1197 
       Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
       Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
       Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
       Type: meltdown mitigation: PTI 
       Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
       Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
       Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
       Type: srbds status: Vulnerable: No microcode 
       Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M] vendor: Hewlett-Packard 
       driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6841 
       Device-2: Primax type: USB driver: uvcvideo bus ID: 3-1.3:4 chip ID: 0461:4dfe serial: <filter> 
       Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: radeon FAILED: ati unloaded: modesetting 
       alternate: fbdev,vesa display ID: :0 screens: 1 
       Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 380x237mm (15.0x9.3") s-diag: 448mm (17.6") 
       Monitor-1: LVDS res: 1440x900 hz: 60 dpi: 118 size: 310x174mm (12.2x6.9") diag: 355mm (14") 
       OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.8.16-2-MANJARO LLVM 10.0.1) v: 3.3 Mesa 20.1.8 compat-v: 3.1 
       direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
       bus ID: 00:1b.0 chip ID: 8086:1e20 
       Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] vendor: Hewlett-Packard driver: snd_hda_intel 
       v: kernel bus ID: 01:00.1 chip ID: 1002:aa90 
       Sound Server: ALSA v: k5.8.16-2-MANJARO 
Network:   Device-1: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: 4000 bus ID: 25:00.0 
       chip ID: 8086:0085 
       IF: wlo1 state: up mac: <filter> 

       Packages: pacman: 1240 lib: 349 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 

Here is the scenario

  1. Wifi connects on first boot.
  2. If no internet is detected/ what ever causing ,-----it disconnects.
  3. I tried to reconnect over to my WIFI or to my Mobile Hotspot, its stucks on configuring device, and then I guess resets and Says “wlo1 not found” but wifi networks are still showing.
  4. tried to recnnect, manually typing passwords, saving passwords for all users. all the same issue stucks on configuring device.
  5. I restart the system, Voila wifi connects to the desired ssid, but the after a few hours, it dosconnects and goes back to loop on number 1 and restart again.

Things I have tried.
.modprobing the driver
.stopping network manager.
.reenabling network manager.
.tried to delete the wlan profile
.checking if kernels were loaded
.ifconfig wlan up and down with sudo
.i cant try any previous kernel versions or downgrading network manager because I have only wifi access, sometimes mobile hostpot and mobile signal here is pretty bad.

Maybe someone could give a hand?

Noticing this:

in combination with:

Does your laptop go into hibernation in mean time?
eg. Do you loose Wifi connection after you wakeup the laptop again?

Not actually, it has been open, actually earlier it disconnected again just like about 10mins after I restarted.

The resume UUID must be associated with my Settings for desktop session which is on Login: Restore previous session; Not sure, I am normally a windows user and just recently migrated to because my windows 10 was freaking me out, eating my ram a lot and I cannot work with my selenium projects.

Hibernation has nothing todo with your GUI login, it is a power-savings mode.
But anyhow i advice you to keep a terminal open with sudo journalctl -f to monitor log entries.
When your connection drops you can see what caused it.
Maybe it would be helpful to paste the relevant parts between ``` (on separate lines by them self) so anyone who likes to help you has some info :wink:
eg:

your log lines
your log lines

PS: no need to post ALL of the log which would be way too much.

Cool, ill monitor that ; thanks will update if my wifi drops again.

Did you ever find a solution for this issue? I am having the same problem with my wireless connection

I don’t know, seems like its a problem of my wifi driver. Have you tried checking you journal? answer might be in there. I am still checking if issue persists. Fortunately i happens only like once week. I bought myself a usb wifi adpater with ar9271 chipset and looks like this is a better solution for me not worrying about bulkiness if the adapter. can you drop your sudo journalctl -f. mine was disconnecting when it reaches a timeout.