Wired Internet Connection Not Working

Ever since last Monday my internet occasionally has been going out, it was however tolerable. As of today it is not working at all. I’ve restarted several times, no solution. I checked the cables, and there’s nothing wrong with the Ethernet itself (plus the Network Manager HAS picked up the connection occasionally but always loses it. I’ve even manually removed the current connection and re-added with the proper MAC address, no improvement. My router is working perfectly fine as well so its not a router problem.

I’m considering just reinstalling to see if that fixes it but before I do that I want to see if anyone may know a way to fix this problem. Thank you ahead of time

Edit: Network Adapter is an Intel I211 on an Asus Prime X470 Pro Motherboard. The driver is listed as ‘igb’.

SOLVED: Turns out I had a network setting messed up the whole time. Problem was fixed by removing device restrictions and setting Link Negotiation to Ignore in the KDE System Settings.

We can’t help you troubleshoot unless you tell us which wired network adapter you have and which driver you’re using. See the pinned post on how to provide good information.

1 Like

oh sorry about that. I’m a bit unsure how to find that out though, I looked online and saw something about a grep command ‘dmesg | grep -i ethernet’ and nothing came up. Is there another way to find that out?

inxi -Nxxxz

will show network adapter information.

inxi -Fxxxza

will show all relevant system information.

Thank you i have just edited my post to include the details

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Did you replace the cable by a brand new one and did you plug the machine straight into the switch / router bypassing all wall sockets?


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

The thing that seems most useful to me is to determine if it is your S.O. to not work or just the internet connection.

Have you tried with a Live Manjaro USB stick to see if it connects?
If you don’t even connect in a Live, you will move on to check your router/cables on another pc/laptop.

If even with that test the connection will not work, then you will need to contact your internet provider.

1 Like