Wired connection continously connects and disconnects


Since a number of days my wired connection started to continuously connects and disconnects. This behavior does not happen when connected with wifi.

I am on a laptop and use a usb-c dongle with a ethernet port.
Checking sudo journalctl -e -u NetworkManager is weird, as sometimes at the moment of disconnection there is some output, but many other times there is nothing when it disconnects.

#################### inxi -Fxzc0 ########################

System:    Kernel: 5.10.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: GNOME 3.38.3 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9360 v: N/A serial: <filter> 
           Mobo: Dell model: 05JK94 v: A00 serial: <filter> UEFI: Dell v: 2.13.0 date: 11/14/2019 
Battery:   ID-1: BAT0 charge: 47.5 Wh condition: 47.5/60.0 Wh (79%) model: SMP DELL TP1GT61 
           status: Full 
CPU:       Info: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Amber/Kaby Lake 
           note: check rev: 9 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21607 
           Speed: 2267 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 2267 2: 700 3: 2311 4: 2275 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: Microdia Integrated Webcam HD type: USB driver: uvcvideo bus ID: 1-5:4 
           Display: x11 server: X.org 1.20.10 driver: loaded: intel unloaded: modesetting 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.4 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 
           Device-2: Logitech HD Webcam C525 type: USB driver: snd-usb-audio,uvcvideo 
           bus ID: 3-1.4:4 
           Sound Server: ALSA v: k5.10.18-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
           vendor: Rivet Networks driver: ath10k_pci v: kernel port: f040 bus ID: 3a:00.0 
           IF: wlp58s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb bus ID: 1-3:3 
           Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           bus ID: 4-1.2:3 
           IF: enp57s0u1u2 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: vpn0 state: down mac: N/A 
Bluetooth: Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb v: 0.8 
           bus ID: 1-3:3 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 953.87 GiB used: 206.94 GiB (21.7%) 
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 953.87 GiB temp: 39.9 C 
Partition: ID-1: / size: 124.99 GiB used: 61.94 GiB (49.6%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 511 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p4 
           ID-3: /home size: 803.53 GiB used: 144.97 GiB (18.0%) fs: ext4 dev: /dev/nvme0n1p3 
Swap:      ID-1: swap-1 type: partition size: 8 GiB used: 36.2 MiB (0.4%) dev: /dev/nvme0n1p1 
Sensors:   System Temperatures: cpu: 56.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 245 Uptime: 3h 22m Memory: 7.5 GiB used: 5.31 GiB (70.8%) Init: systemd 
           Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1589 Client: shell wrapper 
           v: 5.1.0-release inxi: 3.3.01

I followed this solution:

and it somehow worked even though I don’t know why.

I’m glad it worked. Kernels can be funny sometimes. The only suggestion I was going to give you was, “try another kernel”. I’m glad you got it sorted. More power to you meantime. Ruziel :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.