Winetricks sha256mismatch

I’m trying to install vcrun2019 with winetricks and no matter if I delete or rename the file vcrun installer in the cache, or if I run winetricks through Lutris or just by opening the application, nothing gets solved. I need this to run a game and am wondering if there’s some type of command I can use to either fix the issue, or if there will be an update to Winetricks soon. The latter is preferable to me because I’m not savvy with the commandline. But if the former isn’t too hard I will go with that.

I’ve read about the same issues when it comes to someone using Ubuntu for a totally different program installation. I’m not sure if those commands translate to Arch. I’ve tried removing and reinstalling Winetricks through the official repository. It’s a game I want to run that needs vcr2019 and if possible I’d rather not uninstall the other three games I’ve installed over the last couple of days.

Download vcrun2019 x86 or x64 or both, and in Lutris click on your game, and then on the buttons on the right side, click Run EXE inside wine prefix and select the vcrun2019 installer files, then install the files. I found these links from this commit on winetricks github

but you should probably find the installer yourself from Microsoft I didn’t verify the links.

1 Like

Unfortunately it still doesn’t work. I can install the x86 version but not the x64. The installer says I need a newer windows version than XP service pack 1. I’m confused, as in the lutris configuration I have set it to act like windows 10. I will try a 64bit Wineprefix.

EDIT: Had to set it to 64bit to install both of the vcredists. Now it works. Thank you!

Of course you can not install 64 bits executable on 32 bit system :sweat_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.