WINE/Lutris & Starcraft 2

Hi all!

Well, yesterday I posted and asked about a Steam game. Today I’m asking about a Battle.net game.

Well, the thing is, I suspect I’m missing a setting somewhere, or something of thee sort. My reason for saying thyis is quite simple: previously, I played Starcraft 2 using Lutris and Wine without any problems.

Since then, I’ve had a computer format and complete reinstallation, so I’ve obviously lost that installation along with the settings for it.

I’m now trying to get it working again, if fore no other reason than having it there. Everyrthing seems fine. It’s starting up without a hitch. Then you get to the menu area. It all LOOKS fine. If it was a still picture. I get, at most it seems about 1FPS. Alt-Tabbing back to the desktop and running htop in a terminal, showed me a sky-high CPU usage of 100%+ (Which I didn’t even know is possible.)

So, it looks like the GPU isn’t doing the rendering. (Although, I admit I might be wrong about that.)

Does anybody have any ideas as to why this is happening? I’d reaally like to get Starcraft back again.

Edit:
It would seem it’s something to do with disabling the compositor. I guess it makes sense. I’ll just not disable the compositor for running Lutris.

Edit #2:
It would seem I was too early in Celebrating my success yesterday. As trying Cities Skylines again just now wasn’t playable. It was hella laggy! And there wasn’t any real difference.

I just don’t know anymore! I’ll try again tomorroq.

What settings are you using? Mine works with these perfectly. I’m on Nvidia GTX970.

I’ve set mine the same now, with the only difference being the wine version. I had it on the use system option, but changes it to the Lutris one. Except I haven’t got you version, I only have lutris-5.7-11-x86_64 where yours are 6.xx odd.

Try to get mine, click “Manage runners” and for Wine get the latest

Thank you! I just didn’t know where to find it, but your explanation went well!
Unfortunately it still doesn’t work. The game crashes, silently from what I can see, when loading a map. But it turns out it was only the one map (that’s what it looks like, anyway)

So, THANK YOU!

Side question:
What should my CPU usage be? I tried with a simple map just now, just to test, and when I checked with htop it reported 131%. Do you have any idea if and how that’s possible?

Edit:
Just tested again with normal top. It started around 105% While loading, but then became gradually lower when the game started and stopped at about 70%. That’s better. According to me anyway.