Wine issues that doesn't occurs in other distributions

I’d been trying random applications recently to contribute to the Wine AppDB, and then i noted some weird issues.

The first issue i found trying Yamaha Expansion Manager, the application crashes when it’s starting up, but there’s a platinum report on Wine 6.0 on Debian Buster. At first i thought it was a regression and made a regression report on Wine Bugzilla and created a garbage test result report. The fact it were working using older Wine binaries, but still crashing sometimes, while never working on newer binaries, made it even more similar to a regression. When regression testing, i’ve got a wrong commit.

Someone reported on my bug report that they got it working on their system, but hadn’t said what distribution it’s, so i installed ZorinOS on a virtual machine using QEMU and tried this application on Wine 7.0, 7.1 and 7.2, and i got it working, confirming it’s something with my system or Manjaro itself:

I’ve also got something similar on Rufus, where it crashes when clicking “Select” button:

I’ve noted recently another bug that didn’t used to do before, when i open the Wine file explorer by using “Open…” options in some programs, it don’t list anything. Some programs works as expected though

Curious enough is that both Deeds and Rufus report the same thing when reproducing the issue:

014c:fixme:file:errno_to_status Converting errno 75 to STATUS_UNSUCCESSFUL
014c:err:commdlg:IShellBrowserImpl_BrowseObject could not browse to folder

I can still reproduce the exact same issues by creating a new, clean Wine prefix

I need to check if that’s Manjaro’s issue, ¿can you reproduce this issue on your system and tell your system information, please?

These are the applications:

Yamaha Expansion Manager:
Download: Yamaha Expansion Manager V2.6.0 for Windows 10/8.1/7 SP1 - Yamaha - 台灣
SHA1: b6255d5371679554b72f29a00008578438a1bfe6

Rufus 3.17:
SHA1: 4a4501cbd485a1c34e0f667a5767fd2a3554561e

SHA1: cf955581d721c13a9d2de53b56b6060cb76a0f1e

My system information (neofetch):

██████████████████  ████████   joseskvolpe@RaposoPC 
██████████████████  ████████   -------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: Aspire ES1-572 V1.17 
████████            ████████   Kernel: 5.16.7-1-MANJARO 
████████  ████████  ████████   Uptime: 19 hours, 47 mins 
████████  ████████  ████████   Packages: 1592 (pacman) 
████████  ████████  ████████   Shell: bash 5.1.16 
████████  ████████  ████████   Resolution: 1366x768, 1920x1080 
████████  ████████  ████████   DE: Plasma 5.23.5 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   WM Theme: GlowFreeze-Red 
████████  ████████  ████████   Theme: Oxygen [Plasma], X-Vulpus-DarkRed [GTK2/3] 
████████  ████████  ████████   Icons: Obsidian-Red [Plasma], Obsidian-Red [GTK2/3] 
                               Terminal: yakuake 
                               CPU: Intel i3-7100U (4) @ 2.400GHz 
                               GPU: Intel HD Graphics 620 
                               Memory: 8593MiB / 11836MiB 

I’ve verified that wine explorer crashes too, same errno_to_status error output:

07e8:fixme:nstc:NSTC2_fnSetControlStyle2 mask & style (0x00000004) contains unsupported style(s): 0x00000004
07e8:fixme:file:errno_to_status Converting errno 75 to STATUS_UNSUCCESSFUL
07e8:fixme:file:errno_to_status Converting errno 75 to STATUS_UNSUCCESSFUL
wine: Unhandled page fault on read access to 00000000 at address 01322566 (thread 07e8), starting debugger…

I’ve created a new user to try this and Wine explorer and Rufus works without crash, but Yamaha Expansion Manager still crashes

I tried Yamaha Expansion Manager V2.8.1 and it didn’t crash for me, although I didn’t really do much with it. I tested using a fully updated Manjaro KDE (with Plasma 5.24) in virtualbox. I used Wine version 7.2.1 and when I installed wine I installed all the suggested optional dependencies.

I’ve all Wine optional dependencies, except DOSBox. ¿mayeb a buggy testing release?
Guess i’ll wait for the next testing branch release to try Yamaha Expansion Manager again

While that, i need to figure out what’s wrong on my user that makes Wine to crash or glitchy when listing files.

I solved the Wine Explorer and Rufus crash
For some reason that i really don’t know, my Desktop directory traveled to the future to the year 2446, without even bringing me toys and records from the future unfortunately. Wine as a 32-Bits application has issues to read Unix time that exceeds 32-Bits limit. So to solve this i just went to my Desktop directory and used:

touch --date 2022-02-15 .

Yamaha Expansion Manager still crashes though, so let’s keep this thread open
Next time, i hope my desktop invites me to the future too :joy_cat::joy_cat:

Talking again about the future (if Wine still works until there with this limitation…), to whoever is reading this and trying to solve this, you can check what directory is causing crash on Wine by doing:

wine cmd

The file or directory that’s not being listed is causing this issue

1 Like

Updated Wine to 7.2, but problem still exists
That’s weird

¿Maybe a kernel bug?
I’m currently in linux 5.16.10-MANJARO, i’ll try on 5.10 and 5.4 kernels later