Wine applications crashing when calling the GPU

Wine is messed up, and after some reading, the version 510 of the NVIDIA driver doesn’t like Wine.
I tried sudo downgrade linux515-nvidia and got:


So I’ve got: nvidia-utils, nvidia-prime… can’t be bothered to type:

So how do I do it?
Thanks :smiley:

moderation edit to remove some unnecessary remarks

Not sure what that means. I have a software that uses it just fine


Do you use the environment variable
export WINEARCH=win64
or is just as it came after install?

My GPU (GeForce 920MX) + version 510 of the NVIDIA driver doesn’t like wine (it was working until I updated it.)


Someone’s probably going to ask:
Define "messed up".
When running applications, I get:

wine: Unhandled page fault on execute access to 00000000111265A0 at address 00000000111265A0 (thread 0100), starting debugger...

Which crashes the application.

Going to try wine-staging.

You can try to add it to your .bash_profile.
export WINEARCH=win64
Log out and back in.

The thing is MHWD should have installed the video-hybrid-intel-nvidia-prime for your laptop, and not the video-nvidia
so, wine should use the prime-run … same as this

I wanted to update but the post was closed: that isn’t necessary. That’s not true, prime-run is needed, but running Wine with it doesn’t fix the problem.

Also, it doesn’t work when using intel, I’ll try NVIDIA in a minute (didn’t work).

Nothing changed

Also didn’t work, no idea why I even tried it…

As you can see, you can remove video-hybrid-intel-nvidia-prime and install video-hybrid-intel-nvidia-470xx-prime instead …

Driver Version: 470 doesn’t work, I get the same error :sweat_smile:

And DaVinci Resolve doesn’t recognise the GPU, it’s the same version that I had then :point_up: :grin:
Isn’t there a way to install version 495?
Sorry for being so annoying, please don’t slap me :sweat_smile:

Yeah, that is why you should always run the latest supported driver by the system and for your GPU.
To me, that means there is something else with your wine config that is off.
If in doubt, use Play On Linux, create different wine prefixes, either 32 or 64 bit installers and test them out. You can remove them if not working, also you can backup them, set fixed wine versions …

I would have mentioned it. That driver became the 510 one … There is always a way to manually fiddle things from older sources. Is not worth the effort.

Okay, I’ll go back to 510 and look for another solution.

I edited your comment. Please do not mention in the forum information that goes against this forum rule

Okay, sorry about that.
It turned out that the error only happens with specific applications when they call specific…methods, or functions I guess…
i.e. some apps work flawlessly, and some work until I press button x, and some crash while starting up.

I found the method/function it was calling and causing it to crash, two lines before :point_up: :

[0322/] Failed to launch GPU process.
0100:fixme:dwmapi:DwmExtendFrameIntoClientArea (0000000000010E6A, 000000000011E7E8) stub
wine: Unhandled page fault on execute access to 00000000111265A0 at address 00000000111265A0 (thread 0100), starting debugger...

I fixed it by removing and recreating the prefix, then re-installing wine, the changing the windows version from Windows 7 to Windows 10.
I think that changing the Windows version was what solved it.
Thank you @bogdancovaciu for your time, patience and help.

In case anyone wants to know how they can download the older drivers, you can get it from the NVIDIA drivers website, and v495 is listed there.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.