Windows NTFS partition always boots read only!

I have set up a dual boot partitioned drive, Manjaro on one half (accessed by the grub loader menu) and the latest version of Windows on the other.
I have set aside about 100 gig of disc space in a filesystem called ‘EXCHANGE’.
The idea was to place files here that would always be accessible by both partitions. The ‘EXCHANGE’ filesystem is formatted NTFS, since I know Linux can convert on the fly.
I honestly don’t plan to use Windows much, but need it for some things such as Adobe After Effects, etc.
However, Manjaro insists on always mounting the shared drive READ ONLY.
This doesn’t seem to matter even if I sudo nemo and try creating files as root.
There is a drop-down option in Properties to set it to writeable, but there is no APPLY button. So, the change can never be set.
How to make the shared partition writeable on the Linux side?
Otherwise it defeats the whole purpose really :confused:

Do you have fast startup turned on in Windows? If so, turn fast startup off and restart your computer to open Windows again.

Then restart your computer to open Manjaro, and most likely you would be able to access that partition from Manjaro.

It doesn’t convert anything, it uses NTFS-3G to be able to read and write to NTFS. It would be better to use exFAT for shared data between different platforms.

See if this information helps. :wink: :arrow_down:

1 Like

It would be better to use exFAT for shared data between different platforms.>>
NTFS is not a POSIX-compatible filesystem and does not store POSIX file ownership information or permissions.>>

Say no more. I am not married to ntfs.
Since the shared ‘EXCHANGE’ filesystem was empty/not used yet, I tried reformatting it as exFAT instead of ntfs, using GPARTED, after unmounting it.
Now, it appears, my entire system has crashed.
When I boot Manjaro, I only get text:

TIME Timed out waiting for device disk/by/uuid/#######
DEPEND Dependency failed for /EXCHANGE
DEPEND Dependency failed for local file systems.
You are in emergency mode. After logging in, type “journalctl-xb” to view
system logs, “systemctl reboot” to reboot, “systemct default” or “exit” to boot
into default mode.
Give root password for maintenance
(or press control-D to continue)
Reloading system manager configuration
Starting default target

The text on the screen appears to be flickering.
When I type Control-D, it just says:

Reloading system configuration
Starting default target

And sits there endlessly.
Then loops back again to:

Give root password for maintenance
(or press control-D to continue)

Posting this on another computer (running Linux Mint)
Well, guess I bricked Manjaro. It was fun while it lasted…

It’s maybe too late but, to mount my ntfs partitions, what i do in fstab is :

/dev/sda4 /mnt/win_C ntfs-3g gid=1000,dmask=027,fmask=137,noatime,nosuid,nodev,noexec 0 0

So you get -rw-r----- for files and drwxr-x— for folders.
You can change dmak (for directory) and fmask (for files) as you wish.

Yes. NTFS looks a whole lot better now :confused:

I fixed it!!!

Exited out to root prompt, then executed blkid to find the UUID for the EXCHANGE partition.
Then I changed the UUID in the /etc/fstab file to match for that partition (apparently, reformatting it had given it a new UUID). Then the system booted.
However I had already set it back to NTFS.

I wonder if I can do this again, unmount the filesystem, reformat it as exFAT… and then update the UUID in /etc/fstab?
Not sure if I’m bold enough to try at this point lol.