Windows not showing on GRUB - both gpt - GRUB_DISABLE_OS_PROBER=false

Like the title says, I still can’t see windows in GRUB and have tried everything I could find on this topic.

Windows and Manjaro are installed on two seperate ssds, windows was installed first.
Manjaro disk is first in the boot order.

parted -l shows that both are gpt disk.

I’ve added GRUB_DISABLE_OS_PROBER=false to the grub config file, and ran update-grub. Running sudo os-prober returns nothing. I have ntfs-3g installed.

update-grub output looks like this:
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.6-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.6-x86_64.img
Found initrd fallback image: /boot/initramfs-5.6-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
It’s output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings …
Found memtest86+ image: /boot/memtest86+/memtest.bin

Selecting the windows drive in boot override just boots me into manjaro.
EDIT: Looks like my pc is not even reading the windows drive. There are two boot selections for manjaro. One says manjaro, the other says UEFI OS. Windows is not even an option.

I haven’t found any other post in the same situation, usually the problem seems to be that windows is using mdos/legacy instead of gpt. But mine seem to be both as gpt.
Any help is appreciated.

yah i have also problems with other linux distro. even if i disabled os prober.

can you provide

inxi -Fza
sudo mhwd-kernel -li
sudo ls /etc/mkinitcpio.d/*.preset
1 Like

i have the same problem here.

enabled os-prober in grub config.


both windows and linux are running in uefi.

sudo os-prober

gives no results.

i have read, that the linux mounting driver could be an failure point, and it has been recommended to install the ntfs-3g driver for mounting windows partitions, to make Windows visible to os-prober. Unfortunately, i don’t know how to check that yet. i can see that the ntfs-3g package is installed in my manjaro.

❯ inxi -Fza
System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
           root=UUID=c9f4eef2-b12c-46c3-903d-81e9e8bf19de ro quiet splash apparmor=1 security=apparmor 
           resume=UUID=290985d3-85ac-4f77-aeeb-b9da7055bc49 udev.log_priority=3 
           Desktop: GNOME 3.38.4 tk: GTK 3.24.27 wm: gnome-shell dm: GDM Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: STRIX Z270F GAMING v: Rev 1.xx serial: <filter> 
           UEFI: American Megatrends v: 0906 date: 03/22/2017 
Battery:   Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard serial: <filter> 
           charge: 100% (should be ignored) rechargeable: yes status: Full 
CPU:       Info: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: 9 microcode: DE cache: L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 67224 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 
           6: 800 7: 800 8: 801 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: ASUSTeK driver: nvidia v: 460.56 
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1b80 class-ID: 0300 
           Display: x11 server: 1.20.10 compositor: gnome-shell driver: loaded: nvidia 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403 
           Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403 
           Device-3: Razer USA Gaming Webcam [Kiyo] type: USB driver: snd-usb-audio,uvcvideo 
           bus-ID: 1-5:4 chip-ID: 1532:0e03 class-ID: 0102 
           Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.23 running: yes 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel port: f000 
           bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 3.43 TiB used: 40.98 GiB (1.2%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB size: 465.76 GiB 
           block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD 
           serial: <filter> rev: 2B2QEXE7 temp: 36.9 C scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT275MX300SSD1 size: 256.17 GiB 
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> 
           rev: R040 scheme: MBR 
           ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA300 size: 2.73 TiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: ABB0 
           scheme: GPT 
Partition: ID-1: / raw-size: 221.74 GiB size: 217.26 GiB (97.98%) used: 40.98 GiB (18.9%) fs: ext4 
           dev: /dev/sda1 maj-min: 8:1 
           ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) used: 156 KiB (0.0%) fs: vfat 
           dev: /dev/nvme0n1p2 maj-min: 259:2 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 34.43 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 
           maj-min: 8:2 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 54 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 302 Uptime: 25m wakeups: 3 Memory: 31.3 GiB used: 4.26 GiB (13.6%) Init: systemd 
           v: 247 tool: systemctl Compilers: gcc: 10.2.0 Packages: 1470 pacman: 1448 lib: 396 flatpak: 9 
           snap: 13 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.03 

❯ sudo mhwd-kernel -li
Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
   * linux59

❯ sudo ls /etc/mkinitcpio.d/*.preset


I had a similar issue on ubuntu (Installed ubuntu 20.04 first and windows 10 after). Turns out that Ubuntu was installed on legacy and Windows on UEFI, so os prober will never find the windows partition.

The fix was to boot into ubuntu on USB and run boot recovery (search for boot recovery tool)

Once ubuntu UEFI is setup, I had to also change bios setting to boot from UEFI only (options are UEFI only, Legacy only and UEFI + Legacy)

Not sure if this works for Manjaro…

Your kernel has been dead for a while, best install 5.10 LTS and see if that fixes it…