Windows Not Appearing in Grub (But Ubuntu Is)

Hello guys,

First off I’d like to say that I know there are many similar questions, but I’ve gone over many of them and they don’t seem to reflect my specific situation.

I have a laptop with windows and Ubuntu dual booted. At the start everything worked perfectly fine. And I could select Ubuntu or Windows when starting the laptop.

Now, after installing Manjaro, when I boot the computer, the Manjaro GRUB theme appears, and both Manjaro and Ubuntu are options for loading, but Windows is not listed as an option. This happened immediately after installing Manjaro so I’ll give a rundown of how I installed Manjaro -specifically as it relates to partitioning. Unfortunately I didn’t take snapshots during the process, but I have a post-Manjaro snapshot and can explain the things I think are relevant. Of course, I’ll be all too willing to clarify if necessary.

I selected the manual option for installation since the YouTube videos I watched and some threads on this forum advised this. Below are the key points:

Key Points

  • I noticed that there were two smaller partitions in FAT32 format (sda2 and sda5).
  • The Ubuntu partition (sda4) seemed to exist in a kind of “cluster”. When trying to decide what to make the /boot/efi partition, I wasn’t sure which to use between the sda2 and sda5.
  • I went with sda2 because I assumed that was the windows EFI partition, and a video I saw used the windows EFI partition (making sure not to format it, however).

And so I’m in my current situation. Any ideas please? Could it be that the selection of the sda2 partition was wrong?

Also I ran sudo os-prober. This was the result:


As you can see only the Ubuntu shows up.

Can you identify which segment of your hard drive should hold your windows partition? Looking at your screenshot, there seems to be no partition that fit the bill, as this would be likely an ntfs formated partition.

I have the strong suspicion that you installed manjaro over your windows partition.

The NTFS partition is sda3. I’m sure I didn’t. In fact, I can open the partition and look at the windows files in it.

Sorry I didn’t read this correctly, ignore my stupid comment.

It’s no big deal at all. You’re just trying to help and I’m thankful for that.

Yes, in general it means that your HDD has a MS-DOS partition table and not a GPT one, which is recommend for the UEFI.

Better look into that partitions and give them a proper label and partition label. Then you will know which installation created the efi partition.

Are both partitions flagged with “boot, esp” ?

I would guess, since you did a manual partitioning, that you recreated /dev/sda2 and therefore deleted the windows bootloader. Normally, if windows was installed first, the efi partition is every time at the first place. So the windows efi partition should be at /dev/sda1 .