Windows jump to secondary monitor after monitor power off

Related to this I have the same problem. I think the cause is that system sees LG monitor disconnected when it is actually just turned off. It is not a critical problem but is really bothersome.

$ inxi -GSa 
System:
  Host: siavosh-ms7b18 Kernel: 5.19.7-1-MANJARO arch: x86_64 bits: 64
    compiler: gcc v: 12.2.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.19-x86_64
    root=UUID=0baecea2-6a30-4ac4-ab13-4c58bcf15c2f rw quiet
    udev.log_priority=3 zswap.enabled=0
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: Micro-Star MSI
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: HDMI-A-1 empty: DP-1,HDMI-A-2,HDMI-A-3 bus-ID: 00:02.0
    chip-ID: 8086:3e98 class-ID: 0380
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Sapphire Nitro+ driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 ports: active: HDMI-A-5
    empty: DP-2, DP-3, DVI-D-1, HDMI-A-4 bus-ID: 01:00.0 chip-ID: 1002:67df
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu,modesetting alternate: fbdev,vesa gpu: amdgpu,i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1080 s-dpi: 96 s-size: 1182x285mm (46.54x11.22")
    s-diag: 1216mm (47.87")
  Monitor-1: HDMI-A-1 mapped: HDMI-1-1 pos: primary,left
    model: Samsung S22D300 serial: 810242609 built: 2014 res: 1920x1080 hz: 60
    dpi: 102 gamma: 1.2 size: 477x268mm (18.78x10.55") diag: 547mm (21.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-5 mapped: HDMI-A-4 pos: primary,right model: LG
    (GoldStar) ULTRAWIDE serial: 424803 built: 2017 res: 2560x1080 hz: 60
    dpi: 81 gamma: 1.2 size: 798x334mm (31.42x13.15") diag: 869mm (34.2")
    modes: max: 2560x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
    3.47 5.19.7-1-MANJARO) v: 4.6 Mesa 22.1.7 direct render: Yes

First, I’m going to guess you didn’t intend to specifically link to my post in that topic, right? Second, have you tried following the OP’s solution mentioned in the topics last post?

Note, if I understood it correct, he mentioned disabling an option in the monitors own OSD settings.