Windows is mounted as read only. Hybrid Sleep and Fast Startup are disabled, NTFS-3G is installed

What the title says. I’ve logged into Windows and back into Manjaro to see if that will fix the problem, it didn’t. This installation did not used to be like this, I did swap out RAM and motherboard since the last time I was able to write into Windows partition, I don’t know if that would have anything to do with it. Neither Manjaro nor Windows have been reinstalled, since I kept my same storage devices. I also tried manually unmounting and remounting the partition from Manjaro, still only can access it as read-only. I am using Dolphin as my file browser, have never had a problem with it before. What else can I try?

You can run a chkdsk while in Windows to repair any errors (if found.) You might have to run it as an offline scan. (Windows will let you know that it requires rebooting in order to scan and fix errors if the NTFS filesystem is currently in use.)

An alternative (though not as thorough) is to run ntfsfix under Linux.

You need to disable fast startup in windows power options. With fast startup enabled, Linux can mount a ntfs partition as read-only.

I tried chkdsk as an offline scan and restarted. Then I came back to manjaro and ran ntfsfix and this is what it gave me:

Mounting volume… Error opening read-only ‘/dev/sdb3’: Permission denied
FAILED
Attempting to correct errors… Error opening read-only ‘/dev/sdb3’: Permission denied
FAILED
Failed to startup volume: Permission denied
Error opening ‘/dev/sdb3’: Read-only file system
Volume is corrupt. You should run chkdsk.

Which is weird because clearly windows couldn’t find anything wrong with chkdsk. And I’ve heard you shouldn’t change permissions from Linux for Windows partitions because that could mess up the OS. Do you have any other ideas for what it could be?

Nevermind I fixed it. Running ntfsfix as sudo told me that Windows was Hibernated and thus couldn’t be mounted. That was weird, because I had disabled Hibernation through the power settings and had triple checked this. So I went back into windows and had to use powercfg /h off in an elevated command prompt. I guess a windows update turned shut down into hibernate regardless of my setting change.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.