Windows deleted Grub

I dualboot windows 11 and Manjaro. Everytime Windows does an update, it deletes grub. After getting annoyed with manually fixing once every few weeks, is there a way to tell Microsoft to stop deleting grub or have to let them bully for eternity?

Windows does not “delete” Grub, but I think it can overwrite MBR in certain updates if you are using BIOS booting (vs UEFI boot). Can you confirm what type of booting are you using?

Move from MBR to GPT. Windows does not touch existing ESP if already exists, it will simply register its own .efi file there. Been doing this since 2011 (3 years before my migration to Manjaro), never fails.

Wrong. Last time I installed Manjaro on its own SSD, then after installation was complete, I added another SSD to the machine, and installed Windows 10 on it, After reboot, There was no GRUB anymore, Windows used the boot partition from another SSD and overwrote it. It didn’t ask to use that partition, it just used it as if it was its own during the installation process. This is why I ALWAYS leave ONLY the Windows SSD I want to install Windows on, in the machine.

I also have seen on Windows 10 an update overwriting the boot partition somehow (update + automatic repair on reboot, or something like that?).

So definitely Windows does touch the boot partition from other OS without any reason.

And this is all on UEFI system.

Is secure boot enabled in your BIOS setting for UEFI?

AFAIK, secure boot(with valid Windows key) can be controlled by Windows update to change boot order to make Windows boot a high priority, but it does not delete GRUB.
You need to go to BIOS setting to change the boot order and disable secure boot . Secure boot is definitely for Microsoft’s plan to block Linux boot.

I have done the test a few times of installing Manjaro in a VM and then installing Windows. Not a single time has Windows overwritten the ESP/EFI partition. Windows just add its own stuff to there.

My own computer has dual boot and it have been updated to every version of Windows 10 that has been published, and now it has been updated to Windows 11. “Unfortunately” grub is still in place. :slight_smile:

Recovery situations are a different thing and it’s possible that Windows takes more drastic measures in those situations.

It is inconsistent then.

Either that or something else, we’re at least in 2 : 1 situation now, despite I personally never encounter it whether on my own or others. At the worst, some UEFI systems are hardcoded that if they can’t find a boot entry with a particular name they will add it and make it default silently. Note that this is at UEFI firmware level. My company’s Acer laptop (forgot the model) does, my current Lenovo Legion 5 2022 also does. But their Windows never harm my ESP.

3:1 :wink: - I was dual-booting (not currently) for almost a decade (w/ couple dozens of different installs over that time, bare-metal not VM). I’ve not once seen what you were describing, for UEFI systems. I believe you have to be careful when burning ISO e.g. so it’s FAT32 (not NTFS), and by using Rufus or something, I usually did that and had no problems.

There is no score to keep. I’m telling you what can happen. That you have not seen something doesn’t mean it doesn’t exist.

But you also have to admit that there are overwhelming evidence that it does not happen regularly. There are thousands and thousands of dual boot installations across the globe and you can’t find a single verified case of Windows deleting the ESP/EFI partition on regular basis. It’s not reproducible.

What I’m sure is that most people just don’t understand computer boot properly and misunderstand what is actually happening. It can be any other reason. Maybe in some obscure case Windows can mix up things and delete the ESP, but I would say that it is at the same rate that Linux distros can do the same.

PS: Anyway this conversation is not going anywhere :slight_smile:

I’ve seen it happen to gpt/efi as well.
but its not about deleting grub.
It could be fixed even by passing some arguments to (admin) cmd in windoze.
It was more along the lines of hijacking the bootloader or boot order … grub just needed to be fingered again… maybe I can find the command somewhere …

I beileve its something like this, depending on the actual path of course:

bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi

please dear reader do your own research on this as I havent had to do it in a while.

EDIT. Heres an article that seems to cover this … again, I havent heavily verified it.
(scroll down for the windoze section)

I think that is the most that could happen in some cases, but I’m still waiting to happen to me :slight_smile:
(I’m referring to Windows changing the boot order)

It was merely to tone down your wrong, as you said it in the way you think only you were right and we were all wrong. I still need an actual prove, something like an external camera recording in this order:

  1. Boot in GRUB
  2. Choose Windows
  3. Do Windows update
  4. Reboot
  5. Show somehow that it overwrites the ESP instead of just changing the boot order, Windows has mountvol /s that can be used to mount ESP to check it or use something like GParted live, there are many ways, but I need a real proof

Now this one I believe. It’s the same case as I said above, where the UEFI firmware looks for a particular boot entry that when doesn’t exist it adds automatically and set it as default, effectively stopping GRUB or any other boot manager you have from being the default. However, the ESP remains intact. Not overwritten by any means. One case that I personally observe on the spot, is when installing where people tend to just press next without reading what the page is about, and that’s how it ends up overwriting the ESP. Never once I’ve seen Windows update causing it.

Secure boot is disabled.

Agree, my colleagues with the same laptop do not have this challenge. Further, when I dual-booted Ubuntu for 2 years, this was rare. On Manjaro, it has become much more frequent. In any case, rare or not, it’s still a problem. Suggesting I go to another distro to solve this is not the way forward.

I am not using MBR.

This has been happening to me as well and it’s quite annoying, so much so I’m ready to nuke this Windows 11 installation.

I simply boot from a ventoy formatted flash drive and use it to boot Manjaro by way of efi then ran:

sudo pacman -S grub efibootmgr os-prober
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub
sudo grub-mkconfig -o /boot/grub/grub.cfg

I also see this on a regular basis.
3 times out of 4 when updating windows the boot order in my bios is changed to put windows first.
On 2 occasions this year grub bootloader got removed somehow when updating windows (can no longer be found in bios). Chroot in a live env and running update-grub solved it both times.

It DEF happens, but not on every update and I think it also has to do with how microsoft friendly your hardware manufacturer is. I have gigabyte, they are pretty darn ms friendly.

I used to have that problem (with Win 10 dual boot), especially if I chose Windows from the grub menu. As long as I chose a Linus dist entry. from grub, then I would always get a grub menu on reboot. But if I selected Windows, from then on I would keep booting to Windows (no grub), and the UEFI only showed an entry for Windows, instead of previously one for that ,and another for Manjaro/Ubuntu. It was easy enough to fix and restore the Linux entry. But choosing Windows again would mean the loss of my UEFI Linux entry and grub menu, so I’d have to repeat the fix.

Finally I found a permanent solution, by putting Win 10 and my Linux dists on separate disks, and having separate ESPs for both systems. Previously I only had one ESP on one disk. From then on my Linux entry in the UEFI was never deleted, and I always booted to the grub menu.

1 Like