Windows Backup under linux

Dear Forum,

I used to do my backups of Win7 like this. Was working:

dd if=/dev/sdXY of=backup.img
tar -cpf backup.tar /mnt/win

However, with win 10 I get an error, that some file in “Windows - Apps - …” edge.exe (this silly browser) does not give me permissions to do the backup.
How could this even be possible? As root I should have permission to do anything that I mounted, don’t I?

How could I backup my Win 10 C: drive ? How could I copy the whole installation to another machine?
Thanks for advices…


rsync gives me the same error for some files related to Microsoft Edge.

It could be due to how you mounted the filesystem - not sure, of course.

dd will work in any case since this doesn’t care about the filesystem on the device.
I’d - as I have done before - fill the free space in the windows filesystem with zeros before backing it up.
This can be done from Windows itself or also via dd to a huge file on the mounted windows partition - which you then delete once the free space is filled up.
Then pipe the dd output through gzip, the zero bytes will compress to almost nothing and the resulting image file will be much smaller
and the partition will be as big as it was once you restore it.

What I always did was to shrink the partition/filesystem from within Windows to as small as the tool will let you.
This process is quite fast.
Then the following “filling the free space with zeroes” step goes faster since there isn’t much to fill …

like described here and here.

for information:
the links above go to two articles on the Arch wiki, describing the process in detail

Windows has a Fast Startup feature since Win8 that can prevent Linux from accessing the former’s partitions. Have you disabled it?,_refused_to_mount

After considering the important hint from @maycne.sonahoz you could consider using clonezilla for cloning the whole disk.

And this backup can be put on other partitions with different sizes? :wink:


How can I make similar partitions on different drives from console? Lets say with fdisk or cfdisk?

Hello maycne,

your tip worked! Fast startup seemed to be the cause.