Windows and Icons Too Small

Hello, I recently switched from Manjaro Cinnamon to Manjaro Plasma and am getting some new graphical issues. The UI is extremely small. I’ve tried various solutions that I’ve found online over the past couple weeks (mostly involving creating some files to change DPI) but have only succeeded in preventing the system form booting (I reverted breaking changes).

I have also tried changing the global scale in the display configuration. This doesn’t quite work either. For starters, it doesn’t change the scale of the login prompt. It remains the same very small size. GRUB is also barely readable, but I can look past that. But even after logging in, the scale of some UI components is increased, but others remain the same. For example, most buttons and text will be scaled up, but things like spacing and margins will stay the same size, which looks very unpleasant. Furthermore, some of the buttons on window decorations scale up but others do not. Also, when I open a new window, it appears very small if not at the minimum allowable size.

I believe I need to change my DPI but I can’t figure out how. Here is my system info.

    ~  inxi --full --verbosity=7 --filter --no-host                                                                                                                                                 ✔ 
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 17 9710 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 012MMP v: A01 serial: <superuser required> UEFI: Dell
    v: 1.9.1 date: 04/18/2022
  ID-1: BAT0 charge: 73.4 Wh (100.0%) condition: 73.4/95.1 Wh (77.2%)
    volts: 12.6 min: 11.4 model: BYD DELL F8CPG17 type: Li-poly
    serial: <filter> status: full
  RAM: total: 62.54 GiB used: 3.18 GiB (5.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: 8-core model: 11th Gen Intel Core i9-11980HK bits: 64 type: MT MCP
    smt: enabled arch: Tiger Lake level: v4 rev: 1 cache: L1: 640 KiB
    L2: 10 MiB L3: 24 MiB
  Speed (MHz): avg: 848 high: 1020 min/max: 800/4900:5000 cores: 1: 969
    2: 801 3: 800 4: 779 5: 801 6: 800 7: 801 8: 808 9: 995 10: 801 11: 801
    12: 801 13: 903 14: 887 15: 801 16: 1020 bogomips: 105712
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand
    rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect
    ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4
    bus-ID: 00:02.0 chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nvidia v: 515.65.01 arch: Ampere pcie: speed: 5 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:5 chip-ID: 0c45:672e class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2400 s-dpi: 96 s-size: 1016x635mm (40.00x25.00")
    s-diag: 1198mm (47.17")
  Monitor-1: eDP-1 model: Sharp 0x1517 res: 3840x2400 hz: 60 dpi: 266
    size: 366x229mm (14.41x9.02") diag: 432mm (17") modes: 3840x2400
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.6
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8
    class-ID: 0401
  Device-2: NVIDIA GA106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: speed: 5 GT/s lanes: 8
    bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Tiger Lake PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB
    driver: r8152 bus-ID: 2-3.4:4 chip-ID: 0bda:8153 class-ID: 0000
    serial: <filter>
  IF: enp0s13f0u3u4 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:8 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-23525c73-4f89-4565-b8ed-d5f0d3eb731c type: LUKS dm: dm-0
    size: 1.81 TiB
  Components: p-1: nvme0n1p7
  Message: No RAID data found.
  Local Storage: total: 3.78 TiB used: 10.03 GiB (0.3%)
  ID-1: /dev/mmcblk0 model: SD size: 58.24 GiB type: SSD serial: <filter>
    scheme: MBR
  ID-2: /dev/nvme0n1 vendor: KIOXIA model: KXG70PN84T09 NVMe 4096GB
    size: 3.73 TiB speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 10904105 temp: 38.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / size: 1.78 TiB used: 9.94 GiB (0.5%) fs: ext4 dev: /dev/dm-0
    mapped: luks-23525c73-4f89-4565-b8ed-d5f0d3eb731c label: N/A
    uuid: 4fa900a9-183c-4f29-a5f6-2214a736febf
  ID-2: /boot/efi size: 146 MiB used: 89.5 MiB (61.3%) fs: vfat
    dev: /dev/nvme0n1p1 label: ESP uuid: 7019-72CC
  Alert: No swap data was found.
  ID-1: /dev/mmcblk0p1 size: 3.32 GiB fs: iso9660
  ID-2: /dev/mmcblk0p2 size: 4 MiB fs: vfat label: MISO_EFI uuid: C80E-8B3F
  ID-3: /dev/nvme0n1p2 size: 128 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-4: /dev/nvme0n1p3 size: 1.9 TiB fs: bitlocker label: N/A uuid: N/A
  ID-5: /dev/nvme0n1p4 size: 990 MiB fs: ntfs label: WINRETOOLS
    uuid: AC4C9FD14C9F94A4
  ID-6: /dev/nvme0n1p5 size: 16.39 GiB fs: ntfs label: Image
    uuid: A6569FFC569FCB85
  ID-7: /dev/nvme0n1p6 size: 1.37 GiB fs: ntfs label: DELLSUPPORT
    uuid: 7486356B86352F4C
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 2-3:2 info: Realtek Dell dock ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 0bda:0487 class-ID: 0900
  Hub-4: 2-3.3:3 info: Realtek Dell dock ports: 4 rev: 3.1 speed: 5 Gb/s
    chip-ID: 0bda:0413 class-ID: 0900
  Device-1: 2-3.4:4 info: Realtek RTL8153 Gigabit Ethernet Adapter
    type: Network driver: r8152 interfaces: 1 rev: 3.0 speed: 5 Gb/s
    power: 288mA chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 3-4:2 info: Realtek Dell dock ports: 5 rev: 2.1 speed: 480 Mb/s
    chip-ID: 0bda:5487 class-ID: 0900
  Hub-7: 3-4.3:4 info: Realtek Dell dock ports: 6 rev: 2.1 speed: 480 Mb/s
    chip-ID: 0bda:5413 class-ID: 0900
  Device-1: 3-4.3.5:7 info: Dell dock type: HID driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA chip-ID: 413c:b06f
    class-ID: 0300
  Device-2: 3-4.5:6 info: Dell dock type: HID driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA chip-ID: 413c:b06e
    class-ID: 0300
  Device-3: 3-10:3 info: Shenzhen Goodix USB2.0 MISC
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 27c6:63ac class-ID: ef00 serial: <filter>
  Device-4: 3-11:5 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:672e class-ID: 0e02
  Device-5: 3-14:8 info: Intel AX201 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0026 class-ID: e001
  Hub-8: 4-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 327 Uptime: 7m wakeups: 2131 Init: systemd v: 251
  default: graphical Compilers: gcc: 12.1.1 clang: 14.0.6 Packages:
  pm: pacman pkgs: 1169 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.21

This is what the UI looks like with global scale at 100%

This is what the UI looks like with global scale 175%

the dpi is in system settings/fonts/force font dpi

I’m trying to change the global DPI. Not the font DPI.

Bumping this

While a lot of applications do scale with “global scale” in “display configuration,” a lot still do not. Some applications are completely unusable. My previous installation of Manjaro cinnamon did not have this issue. However, audio did not work at all. Using Manjaro KDE, I have audio, but all of my applications are way too small.

try this:
1.set the global scale to 200 and the font dpi to 150;
2.system settings/global theme and check use desktop layout from theme, click defaults then apply;
3.create a new user, log with it and check
4.try a different kernel, dont think this will help, but you should have anyway 2 kernels;
5.provide logs, maybe there will be some hint:
journalctl -b0 -p4 --no-pager