Windows 10 Boot entry missing (Dual Boot for more than a year Manjaro & Windows 10)

Hello. I have been dual booting Manjaro and Windows 10 for more than a year switching to windows 10 in between for certain applications. Recently after an update the grub wouldn’t detect the windows installation. I tried update-grub without any luck. I am able to use Manjaro without any issues but i couldn’t boot into windows.

$ lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 232.9G  0 disk 
├─sda1   8:1    0   867M  0 part 
├─sda2   8:2    0   500M  0 part 
├─sda3   8:3    0   128M  0 part 
├─sda4   8:4    0 189.1G  0 part /run/media/user/OS
├─sda5   8:5    0   510M  0 part 
├─sda6   8:6    0     2G  0 part [SWAP]
├─sda7   8:7    0   200M  0 part /boot/efi
└─sda8   8:8    0  29.3G  0 part /
sdb      8:16   0 931.5G  0 disk 
├─sdb1   8:17   0   500M  0 part 
├─sdb2   8:18   0   128M  0 part 
├─sdb3   8:19   0 472.8G  0 part /run/media/user/Data 1
├─sdb4   8:20   0 445.8G  0 part /run/media/user/Data
├─sdb5   8:21   0   867M  0 part 
└─sdb6   8:22   0  11.5G  0 pa

I installed an additional SSD(250GB) and migrated my windows 10 OS. I installed Manjaro after that.

$ sudo update-grub

Generating grub configuration file ... 
Found background: /usr/share/grub/background.png 
Found linux image: /boot/vmlinuz-5.4-x86_64 
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img 
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img 
Found Windows Boot Manager on /dev/sdb1@/efi/Microsoft/Boot/bootmgfw.efi 
Adding boot menu entry for UEFI Firmware Settings ... 
Found memtest86+ image: /boot/memtest86+/memtest.bin 
done

For some reason, osgrabber is able to detect old windows files of disk 2 but not disk 1. Earlier it used to detect both even though only disk 1 installation was bootable.

$ sudo parted -l

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 
Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  910MB   909MB   ntfs                                          hidden, diag
 2      910MB   1434MB  524MB   fat32           EFI system partition          boot, esp
 3      1434MB  1569MB  134MB                   Microsoft reserved partition  msftres
 4      1569MB  205GB   203GB   ntfs            Basic data partition          msftdata
 5      205GB   205GB   535MB   ntfs                                          hidden, diag
 6      205GB   207GB   2149MB  linux-swap(v1)                                swap
 7      207GB   208GB   210MB   fat32                                         msftdata
 8      208GB   239GB   31.5GB  ext4

Model: ATA ST1000LM014-1EJ1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 
Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  525MB   524MB   fat32        EFI system partition          boot, esp
 2      525MB   660MB   134MB                Microsoft reserved partition  msftres
 3      660MB   508GB   508GB   ntfs         Basic data partition          msftdata
 4      508GB   987GB   479GB   ntfs         Basic data partition          msftdata
 5      987GB   988GB   909MB   ntfs                                       hidden, diag
 6      988GB   1000GB  12.4GB  ntfs                                       hidden, diag

$ efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,0000,0003,000D,000E,0006,000C,000F,0011
Boot0000* manjaro       HD(7,GPT,c064c94e-1712-4dfe-892a-f0b398d50f1f,0x1821c000,0x64000)/File(\EFI\manjaro\grubx64.efi)
Boot0002* USB   VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)
Boot0003* Windows Boot Manager  HD(2,GPT,7ecbd1a3-f9b1-4a93-8f9d-a311114bfdf8,0x1b2001,0xfa001)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}.................
...
Boot0006* NetWork       BBS(PCMCIA,,0x0)..GO..NO........k.N.e.t.W.o.r.k.........................rN.D+..,.\...........<..Gd-.;.A..MQ..L.R.e.a.l.t.e.k. .P.X.E. .B.0.4. .D.0.0........BO
Boot000C* Hard Drive    BBS(Floppy,,0x0)..GO..NO........o.H.a.r.d. .D.r.i.v.e....................A...........................>..Gd-.;.A..MQ..L.3.S.C.3.X.N.H.0.3.5.3.5.7.6. .F. . . . ........BO
Boot000D* Onboard NIC (IPV4)    PciRoot(0x0)/Pci(0x1c,0x4)/Pci(0x0,0x0)/MAC(20474771b44b,0)/IPv4(0.0.0.00.0.0.0,0,0)..BO
Boot000E* Onboard NIC (IPV6)    PciRoot(0x0)/Pci(0x1c,0x4)/Pci(0x0,0x0)/MAC(20474771b44b,0)/IPv6([::]:<->[::]:,0,0)..BO
Boot000F* USB Storage Device    BBS(HD,,0x0)..GO..NO........S.U.S.B. .S.t.o.r.a.g.e. .D.e.v.i.c.e....................A.......................&..Gd-.;.A..MQ..L.N.A.0.K.Q.H.P.5........BO
Boot0011  Second HDD    BBS(Network,,0x0)..GO..NO........o.S.e.c.o.n.d. .H.D.D....................A...........................>..Gd-.;.A..MQ..L. . . . . . . . . . . . .7.W.2.7.3.D.G.X........BO

Is there anyway i can restore my windows boot without affecting the manjaro installation?.

These may help you:

https://wiki.manjaro.org/index.php?title=Preserve_Manjaro_Bootloader

https://wiki.manjaro.org/index.php/GRUB/Restore_the_GRUB_Bootloader

Hi :wave:

If that update was made by windows 10 than you need to reinstall grub and not only update it. Windows like to overwrite the boot behavior.

https://wiki.manjaro.org/index.php/GRUB/Restore_the_GRUB_Bootloader#Reinstall_GRUB

@linuxn00b,
Keep in mind that:

  1. Your UEFI bios will only use the first disk containing an ESP and use that as boot drive.
    The sequence it checks is mostly on a port bases, but can be tweaked in some bioses.
  2. Some windows updates overwrite the default bootloader of the ESP, and/or change the boot order.
  3. IIRC Grub only checks the active ESP, it does not check other ESP partitions on other disks…

So the solution to your problem could be: (one or the other)

  1. Use the ESP of the drive where windows was installed on, without creating another ESP on another drive.
  2. Copy over the \EFI\Microsoft subdirectory recursively from the windows drive’s ESP to your active ESP.

I was wounder about the GRUB/Restore and if it can help me but before i use it, i want to know what BIOS/MBR/GPT system or EFI/GPT system

And this is what my BIOS looks like

UEFI Boot Sources
Manjaro
Windows Boot Manager
USB Hard Drive
USB Floopy/CD and i dont have one installed
UEFI: IPv4 Realtek PCIe GBE Family Controller
UEFI: IPv6 Realtek PCIe GBE Family Controller
Legacy Boot Sources : IS DISABLED
Hard Drive Window10

And if i enable it, tells me Im boot rec is missing :grin:

That just means your system is capable of booting in UEFI-mode only, because you don’t have a legacy boot record aka MBR on your harddisk…
So your current system is most likely EFI/GPT :wink:

My Window10 is on the Legacy that is disable :grinning: but thank for your help
i just not ready to start window up again is so Clunky to run and Manjaro run like a Ninja :+1:

When i tried to reinstall grub i am getting following warning.

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
Installing for x86_64-efi platform.
grub-install: warning: disk does not exist, so falling back to partition device /dev/sda7.
grub-install: warning: disk does not exist, so falling back to partition device /dev/sda7.
grub-install: warning: disk does not exist, so falling back to partition device /dev/sda7.
grub-install: error: disk `hostdisk//dev/sda7' not found.

I am really well versed with the procedures. Can you give more description?

Not sure what you mean, more description of what?