Will this ever get fixed? (AMD RX5xx/Wayland/KDE/Multi-monitor)

About 7 to 8 months ago I decided to try out wayland, and it worked fine for one day and the machine went into sleep and then when I woke it up, it did this and now it does it ever time I start a wayland session. I’ve tried clearing the configs, looking at systemd logs, can’t figure out what causes this and what the problem is.
one monitor displays fine and the other is a lsd induced artwork. The screenshot on the desktop renders correctly but not at the display level.

I figure and I would wait a few months and let wayland, kde and amd develop a bit more, and hope something would get fixed. Today I tried again and same result.

Desktop Specs:
Intel I5 2500k
24GB of ram
Gigabyte Aorus RX 570 4GB
Corsair 750W powersupply
512G Cruical SSD
120G Sandisk SSD
2TB Samsung 5400 rpm HDD
Acer 23" monitor from 2009 1920x1080 60hz
Westinghouse 22" 1680x1050 60hz
O/S: Manjaro 22.0 KDE edition running kernel 6.0.15-1
GPU Driver using the opensource driver in the kernel

I also have a laptop that uses RX 560X which has the same problem as my desktop
Laptop Specs:
Acer Nitro 5
Ryzen 5 2500u
RX 560X also has igpu vega 8
16G of ram
2TB WD Blue ssd
Display 15.6" 1920x1080
External Display is the acer 23" via hdmi at 1920x1080
O/S: Manjaro 22.0 running kernel 5.15
GPU driver: Opensource driver in kernel.

I don’t know how to fix this or where to look specifically for logs pertaining to this problem.
X11 or xorg works fine, just a bit sluggish at times.

Does any one else have this issue or is it a known issue?
Will it ever get fixed?

Edit: Also I forgot to mention, If I logout of wayland session and use sddm to switch X11 Session the problem follows and the only way to not break X11 is to restart the machine and login X11 and not login into wayland.


Apparently the manjaro team is not happy with what I posted and unlisted the topic.

I’m hopping distros. SEE YA!

When the issue appears, then check the log without reboot:

$ journalctl -p err -b 0 --no-pager

“GPU Driver using the opensource driver in the kernel”

Try using the opencl-amd package from AUR

pamac build opencl-amd

I use a RX580 8G and had similar problems with the kernel driver

What’s this?

Please see:

Your post will be hidden until you edit your topic title and first post accordingly.

Help us help you.

Why would you hide this topic?
Do you not see the photo I posted?
I don’t even know how to describe it. But if that’s how the manjaro team wants handle this I’ll gladly hop to another distro.

Sorry Lycan and Zesko for wasting your time but apparently the manjaro team wants to hide the topic, so this may be a fruitless endeavor.

You already made a valiant attempt in your first post.

I can, but search engines cannot. :wink:

The more details you are able to provide, the better chance someone will be able to help you.

Eh, it’s okay. You demonstrated a typical snob like mentality, when I had two others here trying to help me and I was willing to give that information because they ask for it. But now because my post are hidden and topic hidden from view, there’s no point. Now no one will get an answer.
I’m moving on. I’ve been on manjaro since 2016, time for something new, and find different community, that doesn’t handle thread/topics like this.

You still do. That has never changed. Everyone that responds or subscribes to a topic before it’s unlisted can still see it.

It’s not anymore. Is this not visible to you? I thought all members could see it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.