Wifi won't connect on old Macbook Pro (2010 - 7,1 - BCM4322)

Hi !

This is my first time installing Linux, I’m trying to refresh an old Macbook Pro from 2010 (7,1). I made a dual boot with about 200 GB for Manjaro, and to not much surprise, cannot connect to wifi.

What I’ve done so far, still doesn’t work :

  • installed linux headers
  • installed broadcom-wl (for linux61), and then tried broadcom-wl-dkms
  • tried sudo ip link set wlp2s0 up
  • rebooted each time

Read a few similar posts on this forum (cannot include links yet, since I’m a new forum user), and following articles on the wiki :

  • MacBookPro7,1
  • Network_configuration
  • Broadcom_wireless

To be honnest I’m ok with using a terminal but I don’t know much about networks drivers and do not fully understand what I’m doing/reading…

I don’t know what to do next, any help will be welcome :pray:

Here’s my info :

$ inxi --admin --verbosity=7 --filter --width
  Kernel: 6.1.23-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=0ab3885c-ccae-4749-9485-8f1ee49314d6 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro7,1 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-F222BEC8
    serial: <superuser required>
  Mobo: Apple model: Mac-F222BEC8 serial: <superuser required> UEFI: Apple
    v: date: 06/13/2019
  ID-1: BAT0 charge: 45.1 Wh (81.4%) condition: 55.4/66.3 Wh (83.6%)
    volts: 12.2 min: 10.9 model: SMP bq20z451 type: Li-ion serial: N/A
    status: charging cycles: 444
  RAM: total: 3.58 GiB used: 2.66 GiB (74.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core2 Duo P8600 bits: 64 type: MCP arch: Penryn level: v1
    built: 2008 process: Intel 45nm family: 6 model-id: 0x17 (23)
    stepping: 0xA (10) microcode: 0xA0B
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 797 high: 798 min/max: 798/2394 scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 796 2: 798 bogomips: 9560
  Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc
    cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts est flexpriority fpu fxsr ht
    lahf_lm lm mca mce mmx monitor msr mtrr nopl nx pae pat pbe pdcm pebs pge
    pni pse pse36 pti rep_good sep smx sse sse2 sse4_1 ssse3 syscall tm tm2
    tpr_shadow tsc vme vmx vnmi vpid xsave xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA MCP89 [GeForce 320M] vendor: Apple driver: nouveau v: kernel
    non-free: series: 340.xx status: legacy (EOL) last: release: 340.108
    kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm built: 2006-13 ports:
    active: LVDS-1 empty: DP-1 bus-ID: 04:00.0 chip-ID: 10de:08a0
    class-ID: 0300 temp: 76.0 C
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo bus-ID: 1-6:2
    chip-ID: 05ac:8507 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.31x8.31")
    s-diag: 398mm (15.69")
  Monitor-1: LVDS-1 model: Apple 0x9ccb serial: <filter> built: 2009
    res: 1280x800 hz: 60 dpi: 114 gamma: 1.2 size: 286x179mm (11.26x7.05")
    diag: 337mm (13.3") ratio: 16:10 modes: max: 1280x800 min: 640x350
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: NVIDIA MCP89 High Definition Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:08.0 chip-ID: 10de:0d94 class-ID: 0403
  API: ALSA v: k6.1.23-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.68 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl,pavucontrol
  Device-1: Broadcom BCM4322 802.11a/b/g/n Wireless LAN
    vendor: Apple AirPort Extreme driver: wl v: kernel modules: ssb pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:432b class-ID: 0280
  IF: wlp2s0 state: dormant mac: <filter>
  Device-2: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 03:00.0
    chip-ID: 14e4:1684 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 4-6.1:5 chip-ID: 05ac:8213 class-ID: fe01 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 12.22 GiB (2.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 023 scheme: GPT
  Optical-1: /dev/sr0 vendor: ■■■■■■■■ model: DVD-R UJ-898 rev: HC10
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 186.14 GiB size: 182.16 GiB (97.86%) used: 12.2 GiB (6.7%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: 0ab3885c-ccae-4749-9485-8f1ee49314d6
  ID-2: /boot/efi raw-size: 200 MiB size: 196.9 MiB (98.45%)
    used: 15.3 MiB (7.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: EFI
    uuid: 67E3-17ED
  Alert: No swap data was found.
  ID-1: /dev/sda2 maj-min: 8:2 size: 279.3 GiB fs: apfs label: N/A
    uuid: 413e06fb-7e06-416d-be2a-6a1f2f7cb80b
  Hub-1: 1-0:1 info: Full speed or root hub ports: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-6:2 info: Apple Built-in iSight type: Video driver: uvcvideo
    interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 05ac:8507
    class-ID: 0e02 serial: <filter>
  Hub-2: 2-0:1 info: Full speed or root hub ports: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 2-1:2 info: Apple Internal Memory Card Reader type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 05ac:8403 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Full speed or root hub ports: 6 rev: 1.1 speed: 12 Mb/s
    chip-ID: 1d6b:0001 class-ID: 0900
  Hub-4: 4-0:1 info: Full speed or root hub ports: 6 rev: 1.1 speed: 12 Mb/s
    chip-ID: 1d6b:0001 class-ID: 0900
  Device-1: 4-3:2 info: Apple Internal Keyboard/Trackpad (ISO)
    type: Keyboard,HID,Mouse driver: apple,bcm5974,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 40mA chip-ID: 05ac:0237 class-ID: 0301
  Device-2: 4-5:3 info: Apple Built-in IR Receiver type: HID
    driver: appleir,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 100mA
    chip-ID: 05ac:8242 class-ID: 0300
  Hub-5: 4-6:4 info: Broadcom BCM2046B1 USB 2.0 Hub (part of BCM2046
    Bluetooth) ports: 3 rev: 2.0 speed: 12 Mb/s chip-ID: 0a5c:4500
    class-ID: 0900
  Device-1: 4-6.1:5 info: Apple Bluetooth Host Controller type: Bluetooth
    driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 05ac:8213
    class-ID: fe01 serial: <filter>
  System Temperatures: cpu: 73.0 C mobo: N/A gpu: nouveau temp: 76.0 C
  Fan Speeds (RPM): N/A
  Processes: 181 Uptime: 52m wakeups: 2 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1084 libs: 322 tools: pamac pm: flatpak pkgs: 0 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.26

Thank you so much !

You seem to have driver loaded, network interface (ip link show dev wlp2s0). This is a good resource (Archwiki - Network configuration), go through it one by one.
Your interface is dormant, i.e. not up, when doing the ip link set wlp2s0 up see on the side what error messages are you getting (journalctl -r or something similar).
Check this also (and reboot) - Wifi interface staying dormant

1 Like

I’m on a 2009 mbp with the exact same Broadcom chip. Wifi works fine using the B43 driver. Here’s a (lengthy) thread to make it work: Broadcom Wi Fi not working with Manjaro 6.1.12-1 .

Inxi should show:

  Device-2: Broadcom BCM4322 802.11a/b/g/n Wireless LAN
    driver: b43-pci-bridge
1 Like

Hi :slight_smile:
I looked at the topic you linked, tried ip link set wlp2s0 mode default, then ... up again, rebooted, still nothing…

Thanks, I’ll try right away

Hi, just a quick update, I tried b43-pci-bridge but couldn’t get it to work either.

In general, I had a number of lags, bugs, and had to reboot countless times due to freezing while doing simple tasks like watching a youtube video… So I gave up and decided to try another distro (Fedora 38, with broadcom-wl drivers, it surprisingly works).

Thanks a lot for your help, cheers :pray: