Wifi stopped working after update

Yet another Wifi problem, i’m a bit lost.
On my older PC, Wifi stopped working with the March stable update, and the last update did not change anything. I simply can’t connect.
What i tried so far: different kernels, downgrade network manager and libnm to V. 1.32

Some info:

[hph@mini-me Schreibtisch]$ inxi -v2
System:
  Host: mini-me Kernel: 4.19.236-1-MANJARO arch: x86_64 bits: 64
    Desktop: Xfce v: 4.16.0 Distro: Manjaro Linux
Machine:
  Type: Laptop System: Acer product: TravelMate B113 v: V1.05
    serial: <superuser required>
  Mobo: Acer model: BA10_HX v: Type2 - Board Version
    serial: <superuser required> UEFI-[Legacy]: Acer v: 1.05 date: 07/19/2012
Battery:
  ID-1: BAT1 charge: 28.0 Wh (51.9%) condition: 53.9/55.5 Wh (97.2%)
    volts: 11.2 min: 11.1
CPU:
  Info: dual core Intel Core i3-2377M [MT MCP] speed (MHz): avg: 798
    min/max: 800/1500
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    driver: i915 v: kernel
  Device-2: Suyin HD WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
    gpu: i915 resolution: 1366x768~60Hz
  Message: Unable to show GL data. Required tool glxinfo missing.
Network:
  Device-1: Intel Centrino Advanced-N 6235 driver: iwlwifi
  Device-2: Broadcom NetLink BCM57785 Gigabit Ethernet PCIe driver: tg3
Drives:
  Local Storage: total: 223.58 GiB used: 28.08 GiB (12.6%)
Info:
  Processes: 182 Uptime: 3m Memory: 3.69 GiB used: 796.6 MiB (21.1%)
  Shell: Bash inxi: 3.3.15

and

[hph@mini-me Schreibtisch]$ sudo dmesg|grep iw
[    5.457255] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    5.556498] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[    5.897575] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG enabled
[    5.897580] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    5.897583] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    5.897587] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
[    5.982433] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[    6.001047] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[   20.388759] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[   20.724938] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[   20.853168] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[   21.165714] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[   24.718049] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[   25.036838] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[  100.034970] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[  100.353716] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0

Any hints? Which other logs could be helpful?

HP

perhaps run each one of these two commands in a terminal and then try to connect

journalctl -f

and

sudo dmesg -WH

quit each one with CTRL-c

see if the output reveals the reason why it will not …

The dmesg -WH gives no output at all. Journalctl:

Apr 16 14:14:46 mini-me NetworkManager[689]: <info>  [1650111286.2895] device (wlp3s0): supplicant interface state: disconnected -> scanning
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="HierFunktsGewaltig"
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: SME: Trying to authenticate with dc:15:c8:b0:83:3e (SSID='HierFunktsGewaltig' freq=5260 MHz)
Apr 16 14:14:46 mini-me kernel: wlp3s0: authenticate with dc:15:c8:b0:83:3e
Apr 16 14:14:46 mini-me kernel: wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
Apr 16 14:14:46 mini-me NetworkManager[689]: <info>  [1650111286.3298] device (wlp3s0): supplicant interface state: scanning -> authenticating
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: Trying to associate with dc:15:c8:b0:83:3e (SSID='HierFunktsGewaltig' freq=5260 MHz)
Apr 16 14:14:46 mini-me NetworkManager[689]: <info>  [1650111286.3622] device (wlp3s0): supplicant interface state: authenticating -> associating
Apr 16 14:14:46 mini-me kernel: wlp3s0: authenticated
Apr 16 14:14:46 mini-me kernel: wlp3s0: associate with dc:15:c8:b0:83:3e (try 1/3)
Apr 16 14:14:46 mini-me kernel: wlp3s0: RX AssocResp from dc:15:c8:b0:83:3e (capab=0x1011 status=31 aid=19)
Apr 16 14:14:46 mini-me kernel: wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: CTRL-EVENT-ASSOC-REJECT bssid=dc:15:c8:b0:83:3e status_code=31
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: PMKSA-CACHE-REMOVED dc:15:c8:b0:83:3e 0
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: SME: Trying to authenticate with dc:15:c8:b0:83:3e (SSID='HierFunktsGewaltig' freq=5260 MHz)
Apr 16 14:14:46 mini-me NetworkManager[689]: <info>  [1650111286.4247] device (wlp3s0): supplicant interface state: associating -> authenticating
Apr 16 14:14:46 mini-me kernel: wlp3s0: authenticate with dc:15:c8:b0:83:3e
Apr 16 14:14:46 mini-me kernel: wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: SME: Trying to authenticate with dc:15:c8:b0:83:3e (SSID='HierFunktsGewaltig' freq=5260 MHz)
Apr 16 14:14:46 mini-me kernel: wlp3s0: authenticated
Apr 16 14:14:46 mini-me kernel: wlp3s0: authenticate with dc:15:c8:b0:83:3e
Apr 16 14:14:46 mini-me kernel: wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: PMKSA-CACHE-ADDED dc:15:c8:b0:83:3e 0
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: Trying to associate with dc:15:c8:b0:83:3e (SSID='HierFunktsGewaltig' freq=5260 MHz)
Apr 16 14:14:46 mini-me NetworkManager[689]: <info>  [1650111286.5701] device (wlp3s0): supplicant interface state: authenticating -> associating
Apr 16 14:14:46 mini-me kernel: wlp3s0: authenticated
Apr 16 14:14:46 mini-me kernel: wlp3s0: associate with dc:15:c8:b0:83:3e (try 1/3)
Apr 16 14:14:46 mini-me kernel: wlp3s0: RX AssocResp from dc:15:c8:b0:83:3e (capab=0x1011 status=31 aid=20)
Apr 16 14:14:46 mini-me kernel: wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: CTRL-EVENT-ASSOC-REJECT bssid=dc:15:c8:b0:83:3e status_code=31
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: SME: Deauth request to the driver failed
Apr 16 14:14:46 mini-me wpa_supplicant[740]: BSSID dc:15:c8:b0:83:3e ignore list count incremented to 3, ignoring for 60 seconds
Apr 16 14:14:46 mini-me wpa_supplicant[740]: wlp3s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="HierFunktsGewaltig" auth_failures=2 duration=20 reason=CONN_FAILED
Apr 16 14:14:46 mini-me NetworkManager[689]: <info>  [1650111286.6374] device (wlp3s0): supplicant interface state: associating -> disconnected

Should i try to enforce ASPM like described here: https://askubuntu.com/questions/859361/iwlwifi-wireless-issue-cant-disable-aspm-os-doesnt-have-aspm-control?

HP

dmesg will refuse service if you don’t use sudo
sudo dmesg -WH

ps:
ahh, now I undestand
yes, there will be no output
only when you actually try to connect/disconnect
… only new messages will appear
if you don’t do anything, nothing is happening, so there will be no output …

more than once this occurs:

Apr 16 14:14:46 mini-me kernel: wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)

I’d say:
check your router (AP) configuration
or at least power cycle it.

OK, here’s now the dmesg -WH output:

[16. Apr 14:47] audit: type=1111 audit(1650113231.466:113): pid=689 uid=0 auid=4294967295 ses=4294967295 msg='op=connection-activate uuid=150ea2d5-ed9a-4224-a388-a948414db4b5 name=4869657246756E6B7473476577616C7469672031 pid=884 uid=1000 result=success exe="/usr/bin/NetworkManager" hostname=? addr=? terminal=? res=success'
[  +0,026638] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[  +0,329365] iwlwifi 0000:03:00.0: Radio type=0x2-0x1-0x0
[  +0,099896] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
[  +0,139294] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,004347] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,089467] wlp3s0: authenticated
[  +0,004894] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,003421] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,032773] wlp3s0: authenticated
[  +0,019648] wlp3s0: associate with dc:15:c8:b0:83:3e (try 1/3)
[  +0,002338] wlp3s0: RX AssocResp from dc:15:c8:b0:83:3e (capab=0x1011 status=31 aid=26)
[  +0,000009] wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)
[ +10,098965] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,003023] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,012605] wlp3s0: authenticated
[  +0,012907] wlp3s0: associate with dc:15:c8:b0:83:3e (try 1/3)
[  +0,041346] wlp3s0: RX AssocResp from dc:15:c8:b0:83:3e (capab=0x1011 status=31 aid=25)
[  +0,000007] wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)
[  +0,082193] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,003229] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,135101] wlp3s0: authenticated
[  +0,004725] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,003187] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,026264] wlp3s0: authenticated
[  +0,004006] wlp3s0: associate with dc:15:c8:b0:83:3e (try 1/3)
[  +0,001135] wlp3s0: RX AssocResp from dc:15:c8:b0:83:3e (capab=0x1011 status=31 aid=18)
[  +0,000007] wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)
[ +14,360901] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,003693] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,139742] wlp3s0: authenticated
[  +0,003762] wlp3s0: authenticate with dc:15:c8:b0:83:3e
[  +0,003180] wlp3s0: send auth to dc:15:c8:b0:83:3e (try 1/3)
[  +0,024928] wlp3s0: authenticated
[  +0,002415] wlp3s0: associate with dc:15:c8:b0:83:3e (try 1/3)
[  +0,001025] wlp3s0: RX AssocResp from dc:15:c8:b0:83:3e (capab=0x1011 status=31 aid=28)
[  +0,000006] wlp3s0: dc:15:c8:b0:83:3e denied association (code=31)

Router-config (AVM Fritzbox 7530AX) is “allow all devices”, WPA2+3, 2.4+5GHz active. I will try to re-power. The router MAC …3e is the 5GHz. If i force to use networkmanager to use only 2.4GHz output looks similar.

HP

I don’t know - just a hunch:
try setting it to WPA2 only on the router - not the new(er) WPA3

Right now I don’t see any indication in the logs why the association is denied
so this is just trial and error and using the tried and true and trying to narrow it down by excluding WPA3 from the mix, for instance.
You can also try setting this in NetworkManager in the “Sicherheit des Funknetzwerkes” (Security) Tab.

Ah, that did the trick! Setting WPA2(CCMP) on the router and in networkmanager allows connecting, WPA2+3 does not work.

So i cannot use WPA3?

HP

That is not a rhetorical question?
It seems you can’t, since it does not work. :wink:
I always prefer things that do work …

my opinion:
I would not consider that problematic in any way.
Or do you have a reason why you would absolutely want and need to?
I know it did work before and now it doesn’t …
but
I could not be of any help to find out why - I do not own such hardware and thus have no experience.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.