Wifi repeadetly drops with error messages

My wifi disconects from my home router very frequently off late(after Manjaro 20.1 update). It used to happen like once in two hours before, but now the frequency is like once every 10 minutes. It has become exremely frustrating.

I use the Asus RT-N12+ router. Also my router only supports 2.4GHz

The error messages shown are:

  • Authorization supplicant timed out
  • No secrets were provided
  • Wireless interface (wlp0s20f3) was not found

I tired:

  • Removing encryption
  • Switching to Legacy(b/g) mode in my router.

sudo lshw -C network

Click to expand
   description: Wireless interface
   product: Wireless-AC 9560 [Jefferson Peak]
   vendor: Intel Corporation
   physical id: 14.3
   bus info: pci@0000:00:14.3
   logical name: wlp0s20f3
   version: 10
   serial: 14:4f:8a:e0:99:d5
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=5.4.57-1-MANJARO firmware=46.8902351f.0 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:16 memory:a4398000-a439bfff
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0.1
   bus info: pci@0000:06:00.1
   logical name: enp6s0f1
   version: 12
   serial: 98:28:a6:17:c8:54
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.048.03-NAPI latency=0 link=no multicast=yes port=twisted pair
   resources: irq:129 ioport:3000(size=256) memory:a4204000-a4204fff memory:a4200000-a4203fff

System details

Click to expand OS: Manjaro Linux x86_64 KDE Host: Predator PH315-51 V1.19 Kernel: 5.4.57-1-MANJARO CPU: Intel i7-8750H (12) @ 4.100GHz


If there are any other diagnostics that I should run that I can help fix the issue, please let me know.

:+1: Welcome to Manjaro! :+1:

Have you tried any other kernels yet? (System Settings, type kernel in KDE))

I don’t have any other Kernel installed currently.
I tried the initramfs kernel of 5.4.57-1 for a day and I didn’t get any trouble
A couple of reboots later and explicitly selecting the non-initramfs I started getting the same wifi drops but with a much lower frequency, once in 2-3 hours.

Under Manjaro, kernel management becomes a thing: I would keep 2 LTS kernels and at least one experimental:

mhwd-kernel --listinstalled
Currently running: 5.7.15-1-MANJARO (linux57)
The following kernels are installed in your system:
   * linux419
   * linux54
   * linux57

(I’m still on the 5.7, as I don’t line the X.Y.zero releases and only upgrade when they’re at at least a point one release)

If you don’t like a GUI to do this:

mhwd-kernel --install linux57