Wifi range very low on majaro KDE

I have dualboot windows and manjaro. My internet speed is around 300mbps up and down. When I am close to the router or use ethernet I get the speeds I get the speeds I am supposed to be getting. But when I go to my room which has two walls between the router The wifi speed deteriates heavily. On windows I’d get 60mbps up and down at 2.4ghz and 90mbps at 5ghz which is acceptable for me. But on Manjaro I get about 10 mbps 2.4ghz and barely get signal for 5ghz and is heavily unstable.Youtube stats for nerds doesnt go below 40000kbps on windows but on manjaro it cant go over 900 and I cant even watch a 1080p video. How do I get better ranges on wifi in linux.

EDIT: this issue isnt specific to manjaro. I have deteriated wifi performance on every distro I tried. But manjaro seems to be the most sluggish as I cant even watch a youtube video.

It sounds like a powersave options which is on windows not enabled by default.

https://wiki.archlinux.org/index.php/Power_management#Network_interfaces

2 Likes

I have tried that but the problem still persists. I think it has something to do with better drivers on windows.

@galacticwarrior448 Are you sure you use the driver iwlwifi?

Could you post your network devices?

inxi -Nazy
1 Like

Output of inxi -Nazy

Network:
Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel port: 3040 bus ID: 01:00.0 chip ID: 8086:24fb

This is not related to Manjaro, but a combination of configuration and driver / firmware bugs in the iwlwifi kernel module.

The power saving options was turned off for the iwlwifi kernel module on Linux many years ago.

AFAIK the 3168 also bundles the Bluetooth adapter in the same device? Have you tried turning off Bluetooth support in the kernel module and reboot?

Try this:

$ sudo nano /etc/modprobe.d/iwlwifi.conf

And add:
options iwlwifi bt_coex_active=0

to this file, do a reboot and see if that makes any difference.
If so, that is a place to start the troubleshooting, so keep posting the result, if any.

Also, be sure to include the output from
$ uname -r
in your next reply!

2 Likes

Thanks for the reply but I have already added that option to the conf file. No difference.

uname -r output

5.8.13-3-MANJARO

Howdy!

Could you please provide me the output of iwconfig please?

Thank you!:blush:

OK, then it’s time to start troubleshooting!
It’s 05:15 AM where I’m at, so gotta get some Z’s…
I’ll reply later. I know there are many people struggling with iwlwifi interfaces on the latest kernels.
Just one thing before I pass out here, have you tried adding:

acpi=off pci=noacpi

as a boot parameters on startup? Any changes?

Also try manually disabling power saving on your wireless interface:

$ sudo iw dev <devname> set power_save off
(Change with the name of your wlan connection of course.)

Are you dual-booting with Windows on this machine?
If so, make sure to turn off the “fast boot” option, as this may have an impact.
In Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”.
Disable the “Fast Startup” option in “Shutdown Settings”.

Good luck!

1 Like

Did you try the things I mentioned in the last reply?

this is what comes

bash: iwconfig: command not found

I tried the second two things you mentioned it seemed to make a difference. just a little so I can atleast watch netflix. I am a noob a linux. Can you please tell me how to set boot options.

Edit : I tried booting a live manjaro usb and my speeds have doubled. But after installation it goes back to normal.

  1. execute:

    sudo nano --backup /etc/default/grub

  2. look for a line starting with GRUB_CMDLINE_LINUX_DEFAULT= everything between the =" and the last " are boot options / kernel parameters.

  3. Read them all and look how you would add acpi=off pci=noacpi

  4. Correct, add a space before the last " and type acpi=off pci=noacpi

  5. verify again as these are boot option: typo = non-bootable system

  6. now execute:

    sudo update-grub
    # If the above produces errors DO NOT EXECUTE the following command :
    sudo reboot
    
  7. (reply to @cseder)