Wifi randomly gets slow, but doesn't drop entirely


Unfortunately I can’t give out much information on how to reproduce the bug, because it appears randomly

I’m on a laptop, and when I’m using the wifi sometimes it gets so slow that is unusable (200+ ms on pinging the network gateway). Restarting the adapted seems to solve it, but it’s not a really good way of doing things, especially during gaming.

The hardare is probably not at fault, because on Windows 10 it works perfectly, and usually it works well on Manjaro too, but on random intervals it does this.

I have looked at the journalctl for the last 5 times when it happened, and it didn’t really show anything that relates to networking.

The problem persisted through kernel 5.10 and upwards. I’m currently using 5.16.7-1

Some probably useful info:

inxi -n

Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be

Any advice on how to fix it, or at least how to better diagnose it?

Hi @VaranTavers, and welcome!

According to this page on the ArchWiki, there are known problems with the card:

Some users may encounter errors with powersave on this card. This is shown with occasional disconnects that are not recognized by high level network managers (netctl, NetworkManager). This error can be confirmed by running dmesg -w as root or journalctl -f as root and looking for output related to powersave and the rtl8723ae/rtl8723be module. If you are having this issue, use the fwlps=0 kernel option, which should prevent the WiFi card from automatically sleeping and halting connection.

So, try seeing that kernel option. To do so:

  1. Edit the file, for the grub configuration, as root:
sudo nano /etc/default/grub
  1. Look for the line starting with GRUB_CMDLINE_LINUX_DEFAULT= insert fwlps=0 at the end, just before the last quote. For example, mine would then be:
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 fwlps=0"
  1. Save, Ctrl+O, and Exit, Ctrl+X nano.

  2. Update grub:

sudo update-grub
  1. If there were no errors, reboot and test it. And report back.
1 Like

And I though I was tech savvy enough to find that on google.

Thanks a lot, you really helped me, because I had enough of this bug. It happened in the middle of important meetings, and games, or just browsing the internet… I’ll test it for a few days, and after that I’ll mark your answer as the solution.

If that didn’t work, try adding it to the line starting with GRUB_CMDLINE_LINUX. For example:


There were a few hiccups, but none of them seems to be related to the laptop anymore, so it is solved. :smiley: Thanks again, you were a great help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.