Wifi on my laptop constantly ceases to work, but in some rare occasions works again without warning. Not sure if this is a hardware or driver problem

I have this laptop I repaired some years ago (it is a 2013 Samsung model), and for the last 3 years it did its job as an office machine mainly for browsing the web and writing/reading documents.

But there is a problem where the Wifi on the laptop, which was working well some days ago, it ceased completely to function, to the point my laptop doesn’t even show a tab of available network. It only connects to the internet through cable now.

I imagined that this could be some driver problem, because it had been some time I hadn’t updated my kernel (I was using 5.10, and now I tried to install 5.14 but didn’t change much). I also tried to install the drivers correct to my laptop’s network device, which is one of either r810xE or r8169, but every time I try to test any inxi when I install one or another, it changes which driver is it, so I am clueless which one is the real driver for my device.

As of current, I installed both the r8101 and r8169 packages through AUR, although no much success. I also consider the possibility that this is a hardware problem, since the laptop is an old machine, but I don’t believe it is that old nor that damaged to have the wifi poorly working like this, because at the random times it does decide to come back, Wifi works as intended until my computer loses all wifi function again.

Info of my machine through the command inxi -Fxxrz:

System:    Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2
           wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Laptop System: SAMSUNG product: RV411 v: N/A serial: <filter> Chassis: type: 9 serial: <filter>
           Mobo: SAMSUNG model: RV411 serial: <filter> BIOS: Phoenix v: 02RJ.M001.20120214.LG date: 02/14/2012
Battery:   ID-1: BAT1 charge: 12.6 Wh (60.9%) condition: 20.7/32.6 Wh (63.6%) volts: 15.1 min: 14.8
           model: SAMSUNG Electronics type: Li-ion serial: N/A status: Unknown
CPU:       Info: Dual Core model: Intel Core i3 M 380 bits: 64 type: MT MCP arch: Nehalem rev: 5 cache: L2: 3 MiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20226
           Speed: 1463 MHz min/max: 933/2533 MHz Core speeds (MHz): 1: 1463 2: 1564 3: 1463 4: 1443
Graphics:  Device-1: Intel Core Processor Integrated Graphics vendor: Samsung Co driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:0046 class-ID: 0300
           Device-2: Silicon Motion WebCam SC-0311139N type: USB driver: uvcvideo bus-ID: 1-1.4:3 chip-ID: 2232:1020
           class-ID: 0e02 serial: <filter>
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting alternate: fbdev,vesa
           resolution: 1: 1366x768~60Hz 2: 1360x768~60Hz s-dpi: 96
           OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 21.2.3 direct render: Yes
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Samsung Co driver: snd_hda_intel v: kernel
           bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
           Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Samsung Co driver: r8169 v: kernel port: 3000
           bus-ID: 04:00.0 chip-ID: 10ec:8136 class-ID: 0200
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 111.79 GiB used: 48.97 GiB (43.8%)
           ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB speed: 3.0 Gb/s type: SSD serial: <filter>
           rev: 0100 scheme: MBR
Partition: ID-1: / size: 100.87 GiB used: 48.97 GiB (48.5%) fs: ext4 dev: /dev/sda1
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 1.5 MiB (0.0%) priority: -2 dev: /dev/sda2
Sensors:   System Temperatures: cpu: 56.0 C mobo: 56.0 C
           Fan Speeds (RPM): N/A
Repos:     Packages: 1546 pacman: 1539 snap: 7
           Active pacman repo servers in: /etc/pacman.d/mirrorlist
           1: https://manjaro.c3sl.ufpr.br/stable/$repo/$arch
Info:      Processes: 184 Uptime: 34m wakeups: 1 Memory: 5.6 GiB used: 2.6 GiB (46.4%) Init: systemd v: 249 Compilers:
           gcc: 11.1.0 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.07

If this is a hint this is a hardware problem, I wouldn’t mind finding a workaround for it. But if this is something related to some configuration problem, I would be happy to know what I can do.

As discussed in another post, the most probable issue is power management suddenly shut down wifi visibility and processes. Until it happens again, I consider this problem solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.