Wifi not working on my hp laptop

Earlier I was using manjaro on kernel 5.3 which was a stable one.every thing was working fine on that.But I had to reinstall manjaro on another partition so, i reinstalled it and found that kernel 5.3 has been pulledout. Now I am on kernel 5.4 and wifi and display brightness are not working.
I have already deleted windows and stuck on this with no wifi
Please help

Here are system configs:

System:    Host: jai-notebook Kernel: 5.4.60-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
           root=UUID=fa44c4db-b4ac-4b2f-a3ee-739ee3683e24 rw quiet udev.log_priority=3 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15q-dy0xxx v: Type1ProductConfigId 
           serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 84AE v: 86.20 serial: <filter> UEFI: Insyde v: F.10 date: 05/31/2018 
Battery:   ID-1: BAT1 charge: 13.4 Wh condition: 27.2/41.0 Wh (66%) volts: 12.9/11.4 
           model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: Charging 
CPU:       Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx bits: 64 
           type: MT MCP arch: Zen family: 17 (23) model-id: 11 (17) stepping: N/A microcode: 8101007 
           L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 19970 
           Speed: 1368 MHz min/max: 1600/2500 MHz boost: enabled Core speeds (MHz): 1: 1370 2: 1565 
           3: 1384 4: 1595 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
           vendor: Hewlett-Packard driver: amdgpu v: kernel bus ID: 04:00.0 chip ID: 1002:15dd 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa tty: N/A 
           OpenGL: renderer: AMD RAVEN (DRM 3.35.0 5.4.60-2-MANJARO LLVM 10.0.0) v: 4.6 Mesa 20.0.7 
           direct render: Yes 
Audio:     Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Hewlett-Packard 
           driver: N/A bus ID: 04:00.5 chip ID: 1022:15e2 
           Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.4.60-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter vendor: Hewlett-Packard driver: N/A 
           port: 2000 bus ID: 03:00.0 chip ID: 10ec:d723 
           IF-ID-1: enp4s0f3u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 5.25 GiB (0.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
           rev: RSM7 scheme: GPT 
Partition: ID-1: / raw size: 65.67 GiB size: 64.14 GiB (97.67%) used: 5.19 GiB (8.1%) fs: ext4 
           dev: /dev/sda8 
Sensors:   System Temperatures: cpu: 52.2 C mobo: N/A gpu: amdgpu temp: 20 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 194 Uptime: 16m Memory: 3.57 GiB used: 980.4 MiB (26.8%) Init: systemd v: 245 
           Compilers: gcc: N/A Shell: bash v: 5.0.17 running in: xfce4-terminal inxi: 3.0.37 

Reinstall Manjaro but plug in your phone through usb and enable usb tethering inside your device. Mske sure you have enough network at your disposal.

I did it twice and am currently using usb tethering

Have you tried the latest kernel, aka 5.8?

My laptop is old one with outdated hardwares so i dont think latest kernel will work

It doesn’t matter. Even my ancient pc can run the latest kernel, so yours can too. Obviously if it doesn’t work, you can try the prev version, which is 5.7. Besides, what can you loose if you update to the latest anyway?

You don’t have the correct driver for your RTL8723DE wifi card installed. Plug your computer into ethernet, go to this github page, scroll down past the long list of files, and follow the instructions there.