Wifi not working after updating kernels

Wifi not working after updating kernels linux66 and linux67. My wifi is Mediatek MT7922. I am using KDE Plasma and wifi never starts. I’ve got that message inside journalctl

kernel: mt7921e 0000:03:00.0: driver own failed


After a little googling I’ve performed a cold boot and it came to life.


what do you mean by cold boot? In windows it means “a real boot” in contrast to “fast boot” but under linux a boot is always a real boot.

You mean shutdown-start instead of restart?

Let’s hope it lives a long life.

That is typically what a cold boot infers; starting a computer from an off state; this is true no matter which OS is used.

Fast Startup is a hibernation variant, often enabled by default in Windows. If multibooting Linux and Windows, Fast Startup should be disabled in Windows. From an administrative command prompt use the command:

powercfg /h off

Otherwise, Windows will hibernate instead of shutting down; and frequently causes chaos with Linux boot functionality.

Fast Boot is something different entirely – a setting found in the BIOS which allows to skip many self-checks during pre-boot (before handoff to a boot loader).
It is generally recommended to disable Fast Boot when using Linux.

Just some clarification for anyone reading. Cheers.


Reboot to bios. then press and hold power button and… I usually count to 80 and release. This effectively resets all power in the motherboard. And after reboot it should work again. I’ve also added mt7921e to the HOOKS list in /etc/mkinitcpio.conf and run sudo mkinitcpio -P. That cause the system boot to wait at the udev hooks on boot for like 70 sec until the wifi is enabled, but when the graphics stage is reached the wifi is already up and running. sorry for the late response.