Wifi not showing, unable to view wifi settings or connect to wifi

Hi! I have just reinstalled manjaro on my laptop and I do not see the wi fi icon anywhere (bottom right in the taskbar or anywhere else in the settings). I tried to read other posts about this, but none of them helped :frowning: I will provide more information if you need any, but atm the only thing I can tell you is that the command inxi -Nazy returns:

Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0
chip ID: 10ec:8168
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: Hewlett-Packard driver: N/A modules: rtw88_8821ce port: 3000
bus ID: 03:00.0 chip ID: 10ec:c821

Thank you!

Looking through some posts about the device (Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter), I think that the problem is with kernel. So you should first try switching kernels to the LTS release.
Installing this package from the AUR also seems necessary ~ rtl8821ce-dkms-git 1.0.5.r36.gca4abd8-1

You can install the LTS kernel from pamac (add/remove program) by searching for linux-lts. Enable AUR from preferences to install the package rtl8821ce-dkms-git 1.0.5.r36.gca4abd8-1

To switch your kernel, press SHIFT while rebooting to get into the grub menu, choose the advanced options and then select the LTS kernel ( kernel 5.4).
Hope this works for you, have a nice day.

2 Likes

Hello,

In addition to the above, you will need to install the linux headers for your running kernels before installing the rtl8821ce-dkms-git from AUR. The following command from terminal will just do that:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

Then proceed with the AUR package:
pamac build rtl8821ce-dkms-git

1 Like

I installed linux-lts 1:15.4-4 from “add/remove software”. Then I ran the first command that you mentioned and I got an error at some point, but the installation continued anyway so idk if that’s a big issue:

Error! Bad return status for module build on kernel: 4.14.215-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtw88/r45.c63cbee/build/make.log for more information.

Then I ran the last command you gave me and then reboot. I tried to press shift while rebooting, but it did nothing, but it doesn’t matter because my wi fi is working!! Thank you so much!

Well, that is a metapackage and i would not go by that to install the kernel. Always use MHWD for linux kernel and video drivers to install them.

First make sure you have the system updated:
sudo pacman-mirrors -f5 && sudo pacman Syyu
If there are updates, let it finish then reboot.

Either you open the MHWD kernel UI and install one from there, for example 5.4

As you can see i have it installed.
Or you install it from terminal:
sudo mhwd-kernel -i linux54

Is the safest way to install the 5.4 kernel that is LTS. Then you reboot into it. Then proceed to what i described previously. While is safe to have 2 or 3 kernels installed and test them, no need to install them all.

That sounds good, but make sure you don’t clutter the install and you keep it tidy … :slight_smile:

Should I still do what you said above? I’m afraid I’ll break everything again

No need to do it again. Now you do have the linux headers for your running kernel and dkms will take care of the rtl8821ce-dkms-git when there will be another update.

Cool, thank you again! Have a nice day :slight_smile:

1 Like

Ah sorry mate almost ruined your system, when using manjaro always use mhwd for kernel updates, my bad.

@bogdancovaciu thank you for correcting that bro, good day to you.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.