WiFi not found after updates

I recently ran some updates on my system and now my computer isn’t connecting to any WiFi networks but both my home network and the building intranet are visible in the Connections - System Settings window.

On the advice of a friend who knows Linux I ran sudo pacman -Syuu from the Terminal and got the information below.

@MediaLaptop ~]$ sudo pacman -Syuu
:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
there is nothing to do

Prior to running the updates I didn’t have any problems connecting to my WiFi, any advice people could lend on how to fix this would be much appreciated.

Hi @callmegary,
Welcome, pleas post the folowing terminal outputs:
inxi -FN
sudo dmesg | grep usb
rfkill list all

Also, read this post in order to properly put the output.

How to provide good information


I had same issue beginning with kernel 5.8 up to and including 5.10 with my desktop Intel 3168NGW wifi card. None of the suggested troubleshooting made any difference whatsoever.

A blind shot in the dark worked: Boot into the UEFI / BIOS and turn OFF the ethernet. Boot back to desktop and wifi networks now listed and accessible. My guess is something in iwlwifi driver is hosed. Good luck