Wifi Network dialogue screen getting stuck since the 2021-04-09 stable update

CANCEL button is not working, every time when I want to select wifi network I can’t go back and I have to restart my laptop.

Selecting Wifi from manjaro gnome setting is fine though.

Does anyone else have this problem too ? Is there a fix for this problem ?

A few people mentioned this problem in the discussion below the annoucement of the update, but I haven’t found any answer.

Thanks in advance for your help :slight_smile:


A thread in the archlinux subreddit suggests that a fix was merged upstream 3 weeks ago (last time I tried to post the link I was not allowed to do so). No immediate workaround was mentioned. But good that you mentioned that selecting the wifi from the settings works. So I still can change my wifi although it is a bit more complicated.

1 Like

I also have this problem, but found no fix. I tried disabling extensions but issue still persists. It used to work properly not long time ago :confused:

I think it is probably not compatible with Gnome Shell 3.38.
Gnome shell 4.0 might work fine with it, but it is in Manjaro unstable branch.

1 Like

I found the known bug report:


Changing to unstable branch solved the issue


Thanks; I have the same problem. How did you solve it or we have to wait?

If I understand correctly, waiting in stable or switching to unstable are the only solutions

1 Like

I experienced this same issue. The WiFi screen dialogue got stuck and I couldn’t cancel. Manjaro Gnome Testing branch. Didn’t know what to do so I shutdown/restart.

Thanks for finding the bug report @Zesko

Does anyone have an idea how to switch between the different WLAN modules, for example in the terminal?

I think $ wifi-menu will be solution for you.

This is fixed via gnome-shell 1:3.38.4+13+gcf9d73ed5-1


The issue has been fixed for me with the latest 2021-04-19 stable update.

Thanks a lot !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.