Wifi issue with realtek 8822ce

Hello Manjaro Users, I’m a complete newbie here. I’ve recently switched from POP_OS! to Manjaro KDE. The thing is I can’t see available WIFI networks, therefore can’t connect to any WIFI network. The WIFI adapter I have is realtek 8822ce( as shown in windows). It worked fine during the time I used pop os. Please help…

Hi @prathamdhawal, and welcome!

There is a dkms driver in the AUR it seems. So, in theory, it can be installed using:

pamac build rtl88x2ce-dkms

However, for that you’d need some kind of internet connection, even if it’s only temporary.

Otherwise, you can install it manually from the AUR. Although this isn’t something I’ve done myself, so can’t help you with that.

Hope this helps!


Also see GitHub - juanro49/rtl88x2ce-dkms: Realtek RTL8822CE WLAN GNU/Linux Driver in dkms format

1 Like

nope, didn’t work. Ran the command, rebooted, also tried the one from github, didn’t work. thanks.

Perhaps if you provided the output returned we would be able to help with that…