Wifi driver problems on acer aspire switch (sw5-14)

New to linux, but ive tryed my best over the past few days to get the the wifi driver installed, bluetooth works fine and its though. ive tryed so much and im close to giving up. quite frazzled.
what terminal outout can i post for you?

  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=9de1902b-cad3-4c4a-866f-1bbf97b5ef7f ro quiet apparmor=1 
  security=apparmor resume=UUID=c0b4f059-f136-4f94-9a38-bee4904972db 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire SW5-014 v: V1.09 
  serial: <filter> Chassis: type: 9 serial: <filter> 
  Mobo: Acer model: Pancake v: V1.09 serial: <filter> UEFI: Insyde v: 1.09 
  date: 12/17/2015 
  ID-1: BATC charge: 24.8 Wh condition: 27.5/29.7 Wh (92%) volts: 4.2/3.8 
  model: Acer Pancake Battery type: Li-ion serial: <filter> status: Charging 
  cycles: 1 
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A 
  status: N/A 
  Info: Quad Core model: Intel Atom x5-Z8300 bits: 64 type: MCP 
  arch: Airmont family: 6 model-id: 4C (76) stepping: 3 microcode: 368 
  L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11524 
  Speed: 480 MHz min/max: 480/1840 MHz Core speeds (MHz): 1: 480 2: 480 
  3: 480 4: 480 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:22b0 
  Display: x11 server: X Org 1.20.10 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5") 
  s-diag: 599mm (23.6") 
  Monitor-1: DSI1 res: 1920x1200 hz: 60 dpi: 226 size: 216x135mm (8.5x5.3") 
  diag: 255mm (10") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (CHV) v: 4.6 Mesa 20.3.3 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  Imaging Unit 
  driver: N/A alternate: atomisp bus ID: 00:03.0 chip ID: 8086:22b8 
  Sound Server: ALSA v: k5.10.7-3-MANJARO 
  Message: No Device data found. 
  IF-ID-1: enp0s20u2u1c4i2 state: up speed: N/A duplex: N/A mac: <filter> 
  Local Storage: total: 58.25 GiB used: 8.98 GiB (15.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/mmcblk1 maj-min: 179:0 vendor: SK Hynix model: HCG8e 
  size: 58.25 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 0x7 
  ID-1: / raw size: 53.91 GiB size: 52.81 GiB (97.96%) 
  used: 8.77 GiB (16.6%) fs: ext4 dev: /dev/mmcblk1p2 maj-min: 179:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/mmcblk1p1 maj-min: 179:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.05 GiB used: 208.5 MiB (5.0%) 
  priority: -2 dev: /dev/mmcblk1p3 maj-min: 179:3 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 195 Uptime: 34m wakeups: 2 Memory: 1.84 GiB 
  used: 1.46 GiB (79.3%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 1169 lib: 395 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: xfce4-terminal inxi: 3.2.02

Not sure if this is the same issue but same sort/brand see this post on the old, old forum:
Finding out the specific chip and looking for that chip + manjaro or arch is a good starting point.

This made me chuckle

ive tryed this however it never installed a driver for it that i know of in the first place, and didnt work after it tryed.

00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 22)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller (rev 22)
00:03.0 Multimedia controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit (rev ff)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 22)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 22)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 22)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 22)

Again, not sure but your device seems to have the bcm43241 chip and it does have some support issues as read here: [SOLVED] BCM43241 wireless card seems to not exist. / Kernel & Hardware / Arch Linux Forums

Never actually have had this problem so this is a guess. If :point_down: does not help solve it or if you have more questions, post them. Probable solution: en:users:drivers:brcm80211 [Linux Wireless]
Scoll down to For SDIO driver you need to copy the nvram for your system and place it in /lib/firmware/brcm. The nvram file name depends on the chip you have. The kernel log will tell you the exact file name.

i tryed downloading a b 43 firmware from AUR and then sudo modprobe b43. but nothing happened, keep in mind im newb. did i miss somthing?

The package probably has some instructions to follow, I don’t know, please leave the name of the aur package & the command you used + output.

There is a broadcom drivers package (BCM43142)in the community repository, I presumed that you tried that already?

btw How are you downloading this if your wifi is not working?

sudo modprobe b43
no output
installed bcsm43142 reboot no wifi
sudo modprobe b43
no output
usb tethering to iphone witch wont work for the laptops intended purpose going forward, as i need to keep my phone with me, it worked out the box, tbh i dont think i know how to install drivers i thought it would just be as simple as installing them out the manager.
also found the name of the bluetooth/WLAN module :T77H462
i have no idea how to manualy install drivers or force them after install or whatevers going on.

This AUR package b43-firmware ‘latest release’ is 5 years old.
It might work, there are probably some newer and better drivers.

Did you try to install a broadcom package from the community repository. eg Linux510-broadcom-wl?
It might support your chip. (look for the package that matches your installed kernel)


Get your installed kernels from mhwd-kernel -li and install the appropriate broadcom package.

$ mhwd-kernel -li                                                                                    
Currently running: 5.10.7-3-MANJARO (linux510)
The following kernels are installed in your system:
   * linux510
   * linux54

Find the package in the software library (pamac) and check if it is installed, if not, install it.