Wifi driver doesn't work - MediaTek Inc. MT7612U 802.11a/b/g/n/ac Wireless Adapter

Hi All,

I am having an issue with my wifi usb adapter (Alfa AWUS036ACM), it does not work but the chipset should be supported since quite a few kernel versions with the mt76 / mt76-usb driver

lsusb shows this entry:
Bus 002 Device 002: ID 0e8d:7612 MediaTek Inc. MT7612U 802.11a/b/g/n/ac Wireless Adapter

I am currently on kernel
Linux version 6.0.2-2-MANJARO (builduser@fv-az628-669) (gcc (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39.0) #1 SMP PREEMPT_DYNAMIC Sat Oct 15 13:31:58 UTC 2022

but I also tried 5.15.x and 5.19.x

I have a dual boot on this machine with Zorin OS 16 and I run into the same issue. On a laptop with the same Zorin OS version the wifi adapter runs out of the box.

Has anyone an idea what it could be?

Cheers Matt


This might be old, but maybe useful on the archived forum

Thank you, I’ll had a quick look but it does seem to be rather old. Tried to compile one of the suggested drivers but it ran into issues (probably because of the old code). I am not a Linux pro though, just an average user with some knowledge.



In principle it should work starting from 5.5 kernel, according to this Network configuration/Wireless - ArchWiki

Maybe your issue is related to this [SOLVED]mt76x2u driver does not work properly / Newbie Corner / Arch Linux Forums reason why it works on one laptop but not the other.

Thank you so much :slightly_smiling_face: !

This really was the solution:
"The out-of-tree driver is terribly dated, afaics you should be using mt76x2u (check lsmod) and focus on “did not work properly” (see Post complete logs/output/versions/error messages / Newbie Corner / Arch Linux Forums and How To Ask Questions The Smart Way ):

The mt76x2u loads perfectly and shows the wifi networks. Not sure why it is not recognized automatically.

Thanks again for your help!

Cheers, Matthias

1 Like

I have an update. I found out why the wifi dongle wasn’t loaded automatically.
The driver module gets blacklisted when you install the xone driver for the wireless dongle for the Microsoft Xbox Controller. Seems that the two drivers don’t work well together and therefore the xone driver installation blacklists the wifi driver. That’s the reason why the wifi dongle didn’t work for me on 2 different Linux distros. I have the Xbox Controller installed in both installations!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.