WIFI doesn't work with new install, driver is iwlwifi

Can I make some driver changes so that this wifi works? I also tried Linux Mint and it doesn’t recognise it either. Works fine with Windows. “Intel Wireless 8260”.

you may try the following link where you can download the firmware for your wireless nic and copy the file to /lib/firmware.

and i hope this helps

Thank you. In that list there was this, that seems to be the correct one:

Intel® Dual Band Wireless-AC 8260 4.1+ iwlwifi-8000-ucode-25.30.13.0.tgz

I put iwlwifi-8000C-13.ucode with the others in /lib/firmware. But unfortunately enabling the WiFi has no effect. Just wondering whether I’ll be able to get this working from here…

sorry about that but could you try the following

You can load the driver with:

sudo modprobe iwlwifi

hope this helps

Have you installed the linux-firmware package? Please reboot, and then run sudo dmesg | grep iwlwifi and post the output. Please also run inxi -Fazy.

Thanks @a2apple. Tried modprobe and then tried to enable the WiFi but still nothing.

Hi @pobrn. No haven’t tried (and don’t know about) the linux-firmware package. So from dmesg:

[ 3.482329] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[ 3.499361] iwlwifi 0000:01:00.0: Found debug destination: EXTERNAL_DRAM
[ 3.499364] iwlwifi 0000:01:00.0: Found debug configuration: 0
[ 3.499962] iwlwifi 0000:01:00.0: loaded firmware version 36.79ff3ccf.0 8000C-36.ucode op_mode iwlmvm
[ 3.499995] iwlwifi 0000:01:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[ 3.657300] iwlwifi 0000:01:00.0: Detected Intel® Dual Band Wireless AC 8260, REV=0x208
[ 3.667743] iwlwifi 0000:01:00.0: Applying debug destination EXTERNAL_DRAM
[ 3.668293] iwlwifi 0000:01:00.0: Allocated 0x00400000 bytes for firmware monitor.
[ 3.742769] iwlwifi 0000:01:00.0: base HW address: e4:a7:a0:8f:88:8d
[ 4.270307] iwlwifi 0000:01:00.0 wlp1s0: renamed from wlan0

The inxi command:

Network:
Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040
bus ID: 01:00.0 chip ID: 8086:24f3
IF: wlp1s0 state: down mac:

It seems to be detected fine. Does iw list print anything meaningful? Does sudo iw dev wlp1s0 scan work? Do you see anything in dmesg while running these commands?

No and no. iw:

command failed: Network is down (-100)

I looked in dmesg (using sudo dmesg | less) but didn’t see any kind of wifi errors in the most recent logs.