Wifi connected but no internet

I don’t have access to internet even though I’m connected to my WiFi in chromium I get dns probe finished no internet

Hi and Welcome to the fourms.

You haven’t provided a lot of information, so below is a list of various questions that may provide some helpful information to solve the issue:

Do any other devices on your network work properly?

Can you please post the output of ip addr, ip route, and the contents of your /etc/resolv.conf.

Also, can you ping your internet router? The command will be something like this ping 192.168.0.1
Can you ping an internet host? Something like this: ping 172.217.164.195

Can you access any websites by ip?
For example:

# wget 172.217.164.195
    --2020-09-06 14:49:38--  http://172.217.164.195/
    Connecting to 172.217.164.195:80... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: http://www.google.com/ [following]
    --2020-09-06 14:49:38--  http://www.google.com/
    Resolving www.google.com (www.google.com)... 172.217.164.196, 2607:f8b0:400b:801::2004
    Connecting to www.google.com (www.google.com)|172.217.164.196|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: ‘index.html’

    index.html                                 [ <=>                                                                        ]  12.14K  --.-KB/s    in 0.001s  

    2020-09-06 14:49:38 (19.5 MB/s) - ‘index.html’ saved [12434]

Have you tried a different browser? (Eg… firefox)

Hello
1- all the devices are working , when I switch to windows 10 I have internet too
2- nacereasce ]s ip addr
1: lo: <L0OPBACK, UP,LOWER UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 12.0.0.178 Scope host 1o
validlft forever preferredIft forever
ineto1128 SCope host
vallart rorever preferredlft forever
2: enp3s0: <NO-CARRIER, BROADCAST, MULTICASTup mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 20:89: 84:9a:ae: 66 brd ff:ff:ff:ff:ff:ff .
3: wlp4s0: <BROADCAST MULTICAST,UP, LOWER UP mtu 1500 qdisc noqueue state UP group default qlen 1 000
link/ether 24:fd:52:39:9c:19 brd ff:ff:ft:ff:ff:tt
inet 192.168.1.7/24 brd 192.168.1.255scope 8lobal dynamic noprerixroureWpasu

Oa81hf7- Rdbo/64 scope link noprefixroute
forur

Valid lft forever prefer red_lft forever

nacer@asce ]$ ip route
default via 192.168.1.1 dev wlp4s0 proto dhep srE19gR neti 303
192.168.1.0/24 dev wlp4s0 proto dhep scope 1inksre 1926 ect
9.168.1.0/24 dev wip4s0 proto kernel Scope ink stc 92.168 7metric 600 ere re hree other taihgs yo9
haeersee ~]

inacer@asce 1$/etc/resolv.conf
bash: /etc/resolv.conf: Permission denied
Lnacer@asce 1 sudo /etc/resolv.comf
(sudo] password tor nacer
Sudo:etc/resolv. conf: command not found
Lnacereasce ]$ ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) S6(84) bytes of data
nacer@asce ~]s ping 172.217.164.195
ING 172.217.164.195 (172.217.164.195) 56(84) bytes of data.
The same issue with firefox

Thank you.

You did receive an ip, that’s good.

When I asked what is in /etc/resolv.conf – that’s a text file. The command you would use is cat /etc/resolv.conf to see the contents (or open with your favourite GUI text editor) and it should look something like this:

$ cat /etc/resolv.conf 
# Generated by NetworkManager
nameserver 192.168.1.1

Can you redo your ping command with your gateway instead of my example: ping 192.168.1.1

Lastly, when you pinged google (172.217.164.195) did it respond at all or just as you wrote there?

As successful ping looks like this (with the “64 bytes” lines):

 # ping 172.217.164.195
PING 172.217.164.195 (172.217.164.195) 56(84) bytes of data.
64 bytes from 172.217.164.195: icmp_seq=1 ttl=116 time=8.26 ms
64 bytes from 172.217.164.195: icmp_seq=2 ttl=116 time=10.8 ms
64 bytes from 172.217.164.195: icmp_seq=3 ttl=116 time=11.2 ms
1 Like

Hello again and thank you so much for helping me , it’s my first time on Linux and I installed manjaro yesterday it did work perfectly and today when I launched it I got this issue
1-this the result of the commands
nacer@asce ~]$ cat /etc/resolv.config
nameserver 8.8.8.8
nameserver 8.8.4.4
[nacer@asce ~]$ ping 192.168.1.7
PING 192.168.1.7 (192.168.1.7) 56(84) bytes of data.
3 - same with Google it’s just freezed there no response to the command

Hmm, that is interesting.

So, you have an IP and your system is configured to use Google’s DNS servers, but your card cannot reach your router.

the issue isnt immediate obvious to me, maybe others in this forum have ideas, but can you try to disconnect and reconnect your wifi using the GUI network manager. See if that helps.

I’ll read some a bit later and see if I can come up with anything more.

I swear I’m having a whole manjaro page squad helping me for about 3hours lol and nothing , they all told that everything looks fine and they can’t get why I can’t get access to internet
Thank so much

I had a random thought. I wonder if its possible your router is getting confused and simply not answering to your wifi.

Maybe try rebooting your router.

i used timeshift and everything is back to normal , now i don’t know if it’s gonna happen again , but thank you for everything

1 Like