WIFI Atheros QCA6174 firmware issues, hangs

Hello there all,

I’m using Manjaro with

Linux w01 5.15.12-1-MANJARO #1 SMP PREEMPT Wed Dec 29 18:08:07 UTC 2021 x86_64 GNU/Linux

$ lspci

01:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)

This happens only when working on battery.

When this notebook uses the wifi, like updating pacman, its suddenly turn off the screen and shutdown.

Anyone knows how to get more information ?
Pls see journal below (Pastebin)

$ inxi -fazy

CPU:
  Info: model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600103
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1680 high: 2626 min/max: 1400/2375 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1353 2: 1397
    3: 1752 4: 1400 5: 1552 6: 2626 bogomips: 28455
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected

Welcome!

This could be done by TLP. To disable wifi powersave in TLP permanently on battery you don’t have to fiddle with iwconfig or rc.local (won’t work reliable anyway).

Open the file /etc/tlp.conf as root and change on to off in TLP’s configuration instead:

WIFI_PWR_ON_BAT=off

Reboot for changes to take effect.

I swear I documented a situation where an odd Atheros card was causing random freezes (fixable by module options) … I just cant find it…

That is only a small part, and importantly, missing the sections like ‘Network’…
(maybe because of the lowercase f instead of F … I was not sure if typo)

This might help:

Upstream 4 years old…

failed to fetch board data QCA6174 (narkive.com)

ene 09 07:58:01 w01 kernel: ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 11ad:0847
ene 09 07:58:01 w01 kernel: ath10k_pci 0000:01:00.0: kconfig debug 1 debugfs 1 tracing 1 dfs 0 testmode 0
ene 09 07:58:01 w01 kernel: ath10k_pci 0000:01:00.0: firmware ver WLAN.RM.4.4.1-00157-QCARMSWPZ-1 api 6 features wowlan,ignore-otp,mfp crc32 90eebefb
ene 09 07:58:01 w01 kernel: ath10k_pci 0000:01:00.0: failed to fetch board data for bus=pci,vendor=168c,device=003e,subsystem-vendor=11ad,subsystem-device=0847 from ath10k/QCA6174/hw3.0/board-2.bin
ene 09 07:58:01 w01 kernel: ath10k_pci 0000:01:00.0: board_file api 1 bmi_id N/A crc32 70c38a29

also

Problem loading CT ath10k firmware for QCA9984 device (PCI ID 168c:0046) · Issue #172 · greearb/ath10k-ct (github.com)

tl;dr vendors using cheap IoT with $hitty support firmware in Linux. Nihil novi.

https://www.google.com/search?q=failed+to+fetch+board+data+for+from+ath10k

This is not related self with power saving setup. This is directly kernel and firmware crap things.

TLP should be set in /etc/tlp.conf

RUNTIME_PM_DRIVER_BLACKLIST="mei_me nvidia pcieport"

anyway.

I add manually. the whole file its commented.

I’m trying this config

Thanks, also add to my tlp.conf

im waiting to see if crash or not

thanks you all, with this configuration and an update of the firmware

( firmware-6.bin_WLAN.RM.4.4.1-00288-QCARMSWPZ-1)

seems to be working.

Again thanks


EDIT:

The system keeps crashing (3 times today), I will start again to loop up for errors

1 Like