Wifi and other connectivity issues

I’m using an early 2013 MB Pro Retina, 15. 2.7Ghz i7, 1TB SSD, 16GB RAM. My network config is:
NetXtreme BCM57786 Gigabit Ethernet PCIe (Broadcom)
NetXtreme BCM57761 Gigabit Ethernet PCIe (Broadcom)
BCM4331 802.11a/b/g/n (Broadcom)
NetXtreme BCM57761 Gigabit Ethernet PCIe (Broadcom)

The ethernet connection works great. It’s reliable and I get a steady 700-800Mbps. But the Wifi is all over the place. It’s fast enough on initial connection. Perhaps 15-20Mbps but it’s highly variable. I also cannot see my 5Ghz connection which should be getting 400-500 Mbps. The wifi stops and often goes down to .31Mbps or something low like that. I’ve tried doing a wired connection to my iPhone 11 and the speed isn’t really any better. Though oddly, I could be getting 200Mbps on the iPhone but on the connection to Manjaro it’s .24Mbps, but again it could vary widely between about .23-20Mbps but never really any faster than that.

hey, I was just browsing around the arch wiki, saw your question and searched for wifi on apple macs, it seems there are some steps you need to take to get the wifi working correctly depending on the wifi chip used https://wiki.archlinux.org/index.php/Mac#Wi-Fi

You have the Broadcom chip, check out the link :slight_smile:

Searching the broadcom wireless page, there is good info, but nothing tells me how to install the driver properly or remove the bad driver. Running dmesg shows me that I get the same error message over and over, Loading firmware version 666.2. So if I install broadcom-wl via AUR it doesn’t fix the problem as I think the old driver is still there.

Solved the problem. There are many versions of broadcom-wl in the Official Repositories. I chose the one with the highest number at the end linux49-broadcom-wl 6.30.223.271-202. Completely random choice and an odd one since I’m using the 5.10 kernel but it worked. I can now see my 5g network and I’m getting 125Mbps in the area of the house I’m in which is what I should expect to get.
I’ve used several of the other options before and all it would do would be to disable my wifi completely.

Not confident I can explain why this works but happy that it works for you.

It did cause my GUI not to reboot so I reinstalled and then used linux510-broadcom-wl 6.30.223.271-34 and now I do seem to be able to reboot without problems and I’m getting 150Mbps from the same location, which is appropriate.

1 Like