Wifi and Ethernet connection is slow in my home

So I installed Manjaro on my old HP laptop and it’s worked great so far. Except for one thing. For some reason, the connection is painfully slow on my home network. Internet pages take about 15 seconds to load on firefox and I can’t even install things using pacman; the download wont even start. But for some reason, these problems are nonexistent on my campus network. Everything works fine, I can install things with pacman and the internet pages load instantly. I’m new to linux, so I have no Idea what its going on. How do i fix this connection issue? Any help would be appreciated.

  Host: mijo-hpnotebook Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64
    Console: pty pts/2 Distro: Manjaro Linux
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
    serial: 5CG550321D
  Mobo: HP model: 8131 v: KBC Version 30.08 serial: PEMUQ00WB9S0M3
    UEFI: Insyde v: F.11 date: 07/30/2015
  ID-1: BAT0 charge: 958.1 Wh (100.0%) condition: 958.1/958.1 Wh (100.0%)
    volts: 14.0 min: 14.8
  Info: dual core model: Intel Core i7-6500U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1301 min/max: 400/3100 cores: 1: 2570 2: 1635 3: 500
    4: 500
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
  Device-2: Cheng Uei Precision Industry (Foxlink) HP Truevision HD
    type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 22.1.6
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169
  IF: enp1s0 state: down mac: fc:3f:db:46:8d:ae
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    driver: rtl8723be
  IF: wlp2s0 state: up mac: a8:a7:95:96:45:d3
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 931.51 GiB used: 33.44 GiB (3.6%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A9E680
    size: 931.51 GiB
  ID-1: / size: 907.46 GiB used: 32.17 GiB (3.5%) fs: ext4 dev: /dev/sda3
  ID-2: /boot/efi size: 500 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-1: swap-1 type: partition size: 8 GiB used: 1.28 GiB (16.0%)
    dev: /dev/sda2
  System Temperatures: cpu: 41.0 C pch: 40.5 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 234 Uptime: 5h 24m Memory: 7.63 GiB used: 6.88 GiB (90.2%)
  Shell: Zsh inxi: 3.3.21

The first question is: Is your internet slow on other computers/devices?

No, It is not. My android phone, my mother’s apple iPhone and my other windows laptop are working fine. They are fast. It’s only my linux HP notebook.

If you mean the WiFi is slow, try to follow this Wifi randomly gets slow, but doesn't drop entirely - #2 by Mirdarthos

1 Like

as always in case of network problems, pls. provide more info on the network. What is the output of ‘ifconfig’ and ‘ip route’, which DNS do you use, do have a firewall (if so, which rules)? If both Ethernet and WLAN are slow, driver issues are unlikely. Also: maybe google for “speedtest” in your region and see what this says.

a quick check is to boot from live-iso and check if the wifi-connection is different. if so then it is a setting of your installed manjaro, if not the problem might be a setting of your router.

Sure, here are the outputs of
ip addr

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether fc:3f:db:46:8d:ae brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether a8:a7:95:96:45:d3 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic noprefixroute wlp2s0
       valid_lft 84820sec preferred_lft 84820sec
    inet6 fe80::e73b:f71b:2ad9:d723/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

and ip route

ip route

default via dev wlp2s0 proto dhcp src metric 600 dev wlp2s0 proto kernel scope link src metric 600

I also changed the DNS to the google one. That one helped with the speed on firefox and chromium but it still does not solve the problem of the pacman not working.

#  This file is part of systemd.
#  systemd is free software; you can redistribute it and/or modify it under the
#  terms of the GNU Lesser General Public License as published by the Free
#  Software Foundation; either version 2.1 of the License, or (at your option)
#  any later version.
# Entries in this file show the compile time defaults. Local configuration
# should be created by either modifying this file, or by creating "drop-ins" in
# the resolved.conf.d/ subdirectory. The latter is generally recommended.
# Defaults can be restored by simply deleting this file and all drop-ins.
# Use 'systemd-analyze cat-config systemd/resolved.conf' to display the full config.
# See resolved.conf(5) for details.

# Some examples of DNS servers which may be used for DNS= and FallbackDNS=:
# Cloudflare: 2606:4700:4700::1111#cloudflare-dns.com 2606:4700:4700::1001#cloudflare-dns.com
# Google: 2001:4860:4860::8888#dns.google 2001:4860:4860::8844#dns.google
# Quad9: 2620:fe::fe#dns.quad9.net 2620:fe::9#dns.quad9.net

I like playing minecraft and also noted that it wonk work on my home. On my campus it loads instantly. Here in my home it drags on, ask me to authenticate my account and then it’s unable to do so. Speedtest does fine. Ping is 8ms and download and upload are both 30mbps.

Also, how do I boot from a live-iso?

Ok, so I think it is definitely my network. I connected to my mobile hotspot. pacman works instantly and so does the minecraft launcher.

Any idea how to fix it?

What you might have overlooked is that
is not the standard resolver in any Manjaro flavour.

As far as I know, they all use NetworkManager by default.

So: you configuring systemd-resolved is … useless
unless you actually disabled NetworkManager and enabled systemd-resolved instead.

Adapting NetworkManager to use different DNS servers is done differently - certainly not by editing the configuration files of systemd-resolved.

Perhaps that is the “problem” - you are trying to fix a thing that is not even active and used? :wink:

What it appears to come down to is:
your providers DNS server might be slow
but to change that to one that you want ( google or cloudflare or whatever)
you have to configure NetworkManager - it’s easily done via it’s GUI