Wifi adaptor sometimes doesn't work for a while

I’ve been using Manjaro for over a year. Every now and then my wifi adaptor stops connecting to the internet. All I see is the spinning network loading icon. It can do this for anytime from a day to a week, then just start magically working again for weeks/months.

My desktop is actually a dual boot with Windows 8.1, so the first thing I did was switch to the OS to make sure it wasn’t an issue with my internet. It worked fine on Windows, so I booted Manjaro again and the same problem persisted. Then I switched to Windows then back to Manjaro. Behaviour was same as previously mentioned. I also have an older wifi adaptor with a crappy range, which is what I switch to when the problem occurs. I switch between the old and new one daily, until the new one starts working again.

Does anyone have any idea why this might be happening?


More info:

Here’s my wifi adapter model r8188eu (usb d-link)

Today is the 2022-07-27. Here’s the latest update log. I’ve been using the OS since the update with no problems.

[2022-07-24T11:51:52+0300] [ALPM] upgraded xdg-desktop-portal (1.14.4-1 -> 1.14.5-1)
[2022-07-24T11:51:52+0300] [ALPM] upgraded xapp (2.2.12-1 -> 2.2.13-1)
[2022-07-24T11:51:52+0300] [ALPM] upgraded wxwidgets-gtk3 (3.2.0-2 -> 3.2.0-4)
[2022-07-24T11:51:52+0300] [ALPM] upgraded wxwidgets-common (3.2.0-2 -> 3.2.0-4)
[2022-07-24T11:51:51+0300] [ALPM] upgraded woff2 (1.0.2-3 -> 1.0.2-4)
[2022-07-24T11:51:51+0300] [ALPM] upgraded samba (4.16.2-1 -> 4.16.3-1)
[2022-07-24T11:51:51+0300] [ALPM] upgraded smbclient (4.16.2-1 -> 4.16.3-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded rtkit (0.13-1 -> 0.13-2)
[2022-07-24T11:51:50+0300] [ALPM] upgraded python-pyjwt (2.2.0-3 -> 2.4.0-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded python-markdown (3.3.7-1 -> 3.4.1-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded pipewire (1:0.3.55-2 -> 1:0.3.56-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded sbc (1.5-2 -> 2.0-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded os-prober (1.79-1 -> 1.81-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded mpg123 (1.29.3-2 -> 1.30.1-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded manjaro-release (21.3.4-1 -> 21.3.5-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded libnotify (0.8.0-2 -> 0.8.1-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded libbs2b (3.1.0-7 -> 3.1.0-8)
[2022-07-24T11:51:50+0300] [ALPM] upgraded lib32-libldap (2.6.2-1 -> 2.6.3-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded jasper (3.0.4-1 -> 3.0.6-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded hwinfo (21.81-1 -> 21.82-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded hdparm (9.63-2 -> 9.64-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded gtksourceview3 (3.24.11+28+g73e57b57-1 -> 1:3.24.11+r28+g73e57b57-1)
[2022-07-24T11:51:50+0300] [ALPM] upgraded gnome-menus (3.36.0-1 -> 3.36.0-2)
[2022-07-24T11:51:50+0300] [ALPM] upgraded gcr (3.41.0-2 -> 3.41.1-1)
[2022-07-24T11:51:46+0300] [ALPM] upgraded gcab (1.4-1 -> 1.4-2)
[2022-07-24T11:51:46+0300] [ALPM] upgraded code (1.69.1-1 -> 1.69.2-1)
[2022-07-24T11:51:45+0300] [ALPM] upgraded brave-browser (1.41.96-1 -> 1.41.100-1)
[2022-07-24T11:51:44+0300] [ALPM] upgraded libldap (2.6.2-2 -> 2.6.3-1)
[2022-07-24T11:51:43+0300] [ALPM] upgraded alsa-card-profiles (1:0.3.55-2 -> 1:0.3.56-1)

provide formatted output from:
inxi -Fazy

Ok, I think it’s solved and it’s really weird.

So it turns out it was my “internet connection” that was the issue. I switched out my adaptors after the boot to test and the issue was still happening. It worked with one and not the other. But I had a weird feeling about something so I powered off my 4G Huawei B715 mobile router and on again and tested the adaptors. Both adaptors worked!

I have no idea why at some point my mobile router stops connecting to Manjaro only with my d-link adaptor, but there you have it.

Since it was asked, here’s the output to inxi -Fazy

  Kernel: 5.10.131-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=437cf3e6-b08f-4c26-b807-14ea1039cbbd rw quiet
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: N/A v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Gigabyte model: F2A88XM-DS2 v: x.x serial: <superuser required>
    BIOS: American Megatrends v: F1 date: 08/27/2013
  Info: model: AMD Athlon X4 740 bits: 64 type: MT MCP arch: Piledriver
    built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 0x10 (16)
    stepping: 1 microcode: 0x6001119
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB
    desc: d-4x16 KiB; i-2x64 KiB L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 1483 high: 1689 min/max: 1400/3200 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1452 2: 1689
    3: 1397 4: 1397 bogomips: 25561
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Oland PRO [Radeon R7 240/340 / Radeon 520] vendor: XFX Pine
    driver: radeon v: kernel alternate: amdgpu arch: GCN 1 process: TSMC 28nm
    built: 2011-20 pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: gen: 3
    speed: 8 GT/s ports: active: VGA-1 empty: DVI-D-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 1002:6613 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa gpu: radeon
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 96 s-size: 444x277mm (17.48x10.91")
    s-diag: 523mm (20.6")
  Monitor-1: VGA-1 mapped: VGA-0 model: Acer X223W Q serial: <filter>
    built: 2008 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 474x296mm (18.66x11.65") diag: 559mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
    vendor: XFX Pine driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 8 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 1002:aab0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.10.131-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: D-Link type: USB driver: r8188eu bus-ID: 1-5:5
    chip-ID: 2001:331b class-ID: 0000 serial: <filter>
  IF: wlp0s18f2u5 state: up mac: <filter>
  Local Storage: total: 931.51 GiB used: 55.44 GiB (6.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1CH162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC49 scheme: MBR
  ID-1: / raw-size: 694.45 GiB size: 682.48 GiB (98.28%)
    used: 55.44 GiB (8.1%) fs: ext4 dev: /dev/sda5 maj-min: 8:5
  Alert: No swap data was found.
  System Temperatures: cpu: 7.4 C mobo: N/A gpu: radeon temp: 43.0 C
  Fan Speeds (RPM): N/A
  Processes: 214 Uptime: 28m wakeups: 0 Memory: 7.78 GiB
  used: 2.02 GiB (26.0%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: pacman: 1129
  lib: 316 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.19

so is it fixed or you still have the issue?

It’s fixed. Sorry, I forgot to mark the solution, and have updated it now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.