Wifi adapter not found RTL8821CE


I have Lenovo L340 and the wifi is not recognized. I tried to install the driver, but when I was executing “modprobe”, there was an error stating that the file cannot be found in modules. Below you will see listed information regarding my device.

Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo driver: rtl8821ce v: N/A 
       modules: 8821ce port: 4000 bus ID: 07:00.0 chip ID: 10ec:c821 
       IF: wlp7s0 state: down mac: <filter>

Did you install the rtl8821ce-dkms-git package together with the headers for your kernel?

PS: it looks like your wifi card is detected just fine by the system.

I have the same chip and work just fine with that driver, just install it from AUR
If you’re using kernel 5.8 then
sudo pacman -S linux58-headers
if you’re using other kenerl series like 5.4 then change linux58 to linux54

yay -S rtl8821ce-dkms or the git version yay -S rtl8821ce-dkms-git
uname -r

Just install the headers first. Else the dkms module can’t build.


It worked. Thanks, both :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.