WiFi adapter issues on boot with open source drivers

Migrating from windows here. I made a bootable drive and tried out manjaro (KDE plasma flavour), first with open source drivers, I have an amd GPU.

My network adapter (WiFi 6E on the B650I MSI motherboard) didn’t work and I was stuck with Ethernet which I can’t use.

I booted back into windows and the network card was bricked! So I cleared the CMOS and booted back in window again, this time it was fixed.

Booting in manjaro with proprietary drivers didn’t kill my WiFi, and so I installed it.

Booting with my now manjaro disk, my network card’s bricked again. I suppose it installed and assumed to use open source drivers?

I could just clear CMOS again, but how do I allow manjaro to use the correct driver without internet?

I could sideload something from my phone but it only goes so far, I can’t run pacman on android lol.

Ask me anything you need to know, I’ll answer with what I know.

IT’S FINE NOW??? WiFi just didn’t show up early after boot? I waited a few minutes and now it works, but I’ll keep this open if it troubles me again.

Sure you can Pacman on Android.

This seems normal for many laptops.