Wifi adapter doesn't work on Live CD or fresh install

My wifi doesn’t work on a new laptop with a fresh install of Manjaro, dual boot with Windows. It also doesn’t work on Live usb. It works on windows. I don’t appear to have the driver installed.

  • Secure Boot disabled in bios
  • Fast boot disabled in Windows
  • Latest KDE iso

A major problem is that I can’t get internet on it, I don’t have ethernet access, and bluetooth tethering doesn’t work on this fresh install for some reason, and I don’t have usb cables.

Output of inxi -N is:

Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
Device-2: Realtek driver: N/A

From my research, I tried the following:

  • Install linux510-headers. I downloaded them from my other laptop using sudo pacman -Sw linux510-headers, copied them over and installed them, this seems to have gone fine but didn’t fix anything.
  • Followed these directions to try to install rtl8812au-dkms-git, however this fails with cannot resolve dkms So I tried to download and install dkms-2.8.4-1 from a separate computer but then I got other missing dependencies for gcc, make, patch, when I tried to manually install gcc I got more missing dependencies and gave up. I’m not even sure if this is the right driver.

I don’t actually know what I’m doing so I’m asking for help here, thanks.

  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=06607066-d1b6-44bc-a2fe-d448a742d343 rw quiet apparmor=1
  security=apparmor resume=UUID=ff60761a-ed20-44ad-abe7-479f270650b6
  Desktop: KDE Plasma 5.21.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82JQ v: Legion 5 Pro 16ACH6H
  serial: <filter> Chassis: type: 10 v: Legion 5 Pro 16ACH6H serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter>
  UEFI: LENOVO v: GKCN36WW date: 04/21/2021
  ID-1: BAT0 charge: 32.6 Wh (38.9%) condition: 83.7/80.0 Wh (104.6%)
  volts: 15.0 min: 15.4 model: Sunwoda L20D4PC1 type: Li-poly serial: <filter>
  status: Discharging cycles: 4
  RAM: total: 15.57 GiB used: 1.42 GiB (9.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: 8-Core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
  type: MT MCP arch: Zen 3 family: 19 (25) model-id: 50 (80) stepping: 0
  microcode: A50000B cache: L2: 4 MiB bogomips: 102245
  Speed: 1397 MHz min/max: 1200/3200 MHz boost: enabled Core speeds (MHz):
  1: 1397 2: 1397 3: 1198 4: 1198 5: 1198 6: 1196 7: 1198 8: 1197 9: 1198
  10: 1198 11: 1197 12: 1197 13: 1198 14: 1197 15: 1197 16: 1198
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
  cr8_legacy cx16 cx8 de decodeassists erms extapic extd_apicid f16c
  flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
  invpcid irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor
  movbe msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx ospke osvw
  overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core
  perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt pse pse36 rdpid rdpru
  rdrand rdseed rdt_a rdtscp rep_good sep sha_ni skinit smap smca smep ssbd
  sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
  topoext tsc tsc_scale umip v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall
  vpclmulqdq wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW,
  STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA vendor: Lenovo driver: nvidia v: 465.31
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:2560
  class-ID: 0300
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver:
  loaded: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 191 s-size: 340x221mm (13.4x8.7")
  s-diag: 406mm (16")
  Monitor-1: DP-4 res: 2560x1600 hz: 60 dpi: 188 size: 345x215mm (13.6x8.5")
  diag: 407mm (16")
  OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2
  v: 4.6.0 NVIDIA 465.31 direct render: Yes
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes
  Sound Server-2: JACK v: 0.125.0 running: no
  Sound Server-3: PulseAudio v: 14.2 running: yes
  Sound Server-4: PipeWire v: 0.3.30 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek vendor: Lenovo driver: N/A port: 1000 bus-ID: 04:00.0
  chip-ID: 10ec:8852 class-ID: 0280
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
  bus-ID: 3-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends
  Permissions: Unable to run lvs. Root privileges required.
  Message: No RAID data found.
  Local Storage: total: 1.92 TiB used: 8.03 GiB (0.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: SK Hynix model: HFS001TDE9X084N
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: 41010C22 temp: 33.9 C
  scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: SK Hynix model: HFS001TDE9X084N
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: 41010C22 temp: 35.9 C
  scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Fit
  size: 58.73 GiB block-size: physical: 512 B logical: 512 B serial: <filter>
  rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  ID-1: / raw-size: 944.77 GiB size: 928.86 GiB (98.32%) used: 8.03 GiB (0.9%)
  fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:3 label: N/A
  uuid: 06607066-d1b6-44bc-a2fe-d448a742d343
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:2
  label: NO_LABEL uuid: 7EFC-9CAC
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme1n1p3 maj-min: 259:4 label: N/A
  uuid: ff60761a-ed20-44ad-abe7-479f270650b6
  ID-1: /dev/nvme0n1p1 maj-min: 259:5 size: 260 MiB fs: <superuser required>
  label: SYSTEM_DRV uuid: 6460-8826
  ID-2: /dev/nvme0n1p2 maj-min: 259:6 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:7 size: 952.62 GiB
  fs: <superuser required> label: Windows-SSD uuid: 8E9661089660F25F
  ID-4: /dev/nvme0n1p4 maj-min: 259:8 size: 1000 MiB fs: <superuser required>
  label: WINRE_DRV uuid: 8E4861AE486195AD
  ID-5: /dev/sda1 maj-min: 8:1 size: 2.74 GiB fs: <superuser required>
  label: MANJARO_KDE_2107 uuid: 2021-06-14-15-33-09-00
  ID-6: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: <superuser required>
  label: MISO_EFI uuid: 0ACC-C46C
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 3 rev: 2.1 speed: 480 Mb/s
  chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-4:3 info: Integrated Express ITE Device(8910) type: Keyboard
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 048d:c101 class-ID: 0301
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-2:2 info: Genesys Logic USB3.2 Hub ports: 3 rev: 3.2 speed: 5 Gb/s
  chip-ID: 05e3:0620 class-ID: 0900
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:4 info: SanDisk Cruzer Fit type: Mass Storage
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
  chip-ID: 0781:5571 class-ID: 0806 serial: <filter>
  Device-2: 3-3:2 info: Integrated Express ITE Device(8295) type: Keyboard,HID
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 048d:c965 class-ID: 0300
  Device-3: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb
  interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA chip-ID: 0bda:4852
  class-ID: e001 serial: <filter>
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Message: No sensor data found. Is lm-sensors configured?
  Processes: 297 Uptime: 1h 09m wakeups: 7 Init: systemd v: 248
  tool: systemctl Compilers: gcc: N/A Packages: pacman: 1174 lib: 319
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.04

I guess it is this one:

Why? Because of the chipid: 10ec:8852

Open a mirror at the browser:


(kernel and headers have to match exactly)

The download the repo:

git clone https://aur.archlinux.org/rtw89-dkms-git.git

install also base-devel:

pamac install base-devel

Now create the package:

cd rtw89-dkms-git
makepkg -src

This will create the dkms package in the same folder.

Now put the packages on the laptop without internet and run:

cd folder-which-contains/packages
sudo pacman -U *.tar.zst

Thanks, I followed your instructions, when installing on the target machine I still get:

warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
loading packages...
warning: linux510-headers-5.10.52-1 is up to date -- reinstalling
resolving dependencies...
warning: cannot resolve "dkms", a dependency of "rtw89-dkms-git"
:: The following package cannot be upgraded due to unresolvable dependencies:

Is there a way to download DKMS and all of it’s dependencies for install at once?

mkdir ~/pkgcache
sudo pacman --cachedir $HOME/pkgcache -Syw linux510 linux510-headers dkms base-devel

That should download the packages to ~/pkgcache, which can be installed on the other system with:

sudo pacman -U *.tar.zst

Thanks, that seems to be exactly what I want but after I run it ~/pkgcache still appears to be empty:

[davidb@DavidSpectre pkgcache]$ sudo pacman --cachedir $HOME/pkgcache -Syw linux510 linux510-headers dkms base-devel
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: There are 24 members in group base-devel:
:: Repository core
   1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file  7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff
   14) gzip  15) libtool  16) m4  17) make  18) pacman  19) patch  20) pkgconf  21) sed  22) sudo  23) texinfo  24) which

Enter a selection (default=all): 
resolving dependencies...

Packages (28) pahole-1.21-1  autoconf-2.71-1  automake-1.16.3-1  binutils-2.36.1-3  bison-3.7.6-1  dkms-2.8.4-1  fakeroot-1.25.3-2  file-5.40-5
              findutils-4.8.0-1  flex-2.6.4-3  gawk-5.1.0-1  gcc-11.1.0-1  gettext-0.21-1  grep-3.6-1  groff-1.22.4-6  gzip-1.10-3
              libtool-2.4.6+42+gb88cebd5-16  linux510-5.10.52-1  linux510-headers-5.10.52-1  m4-1.4.19-1  make-4.3-3  pacman-6.0.0-2  patch-2.7.6-8
              pkgconf-1.7.3-1  sed-4.8-1  sudo-1.9.7.p1-1  texinfo-6.8-1  which-2.21-5

Total Download Size:  0.00 MiB

:: Proceed with download? [Y/n] y
(28/28) checking keys in keyring                                                          [####################################################] 100%
(28/28) checking package integrity                                                        [####################################################] 100%
[davidb@DavidSpectre pkgcache]$ ls
[davidb@DavidSpectre pkgcache]$

I don’t think this is going to work. I used -Syp to list the packages instead, then I copied them to a USB 1 by 1. I used pacman -U *.tar.zst to install them all, but still got a lot of dependancy warnings, and some errors of breaking dependencies. This doesn’t seem like a good way to do it.

I might give up and try a different distro… :sob: It’s too difficult to get internet working without internet…

Since the driver is not there by default, you have to use a wired connection or a phone connection via usb. Any workaround will be a hassle as you see, especially on a rolling release. On fixed releases like debian, ubuntu and sort of you might have a better chance. But the driver isn’t included there also.

@dave90 I hope you haven’t given up on Manjaro! I too recently got a Legion 5 Pro (it looks like it’s the same one you have) and found the wifi was not working (among a couple other things). But I stumbled across a number of other posts that gave me enough clues to point me in the right direction. So I’m paying it forward and hoping I can help you get your wifi working as well. Try this procedure out – it’s really and surprisingly simple but if you run into any obstacles, just holler and I’ll see if I can help.

With Ethernet connected, start pamac (the utility to install software), search for these packages (they will all be in AUR):


They should all be there. Install each of them in sequence (you might be able to check them all and apply the install at once, but I did each install individually and in sequence).

Following the install, do a full shutdown; boot up again (with Ethernet still attached); you should now see both the wired and wireless up and running; disconnect the Ethernet to test the wireless; the wireless should be working (you will, of course, have to log in to your router with your wireless password)!