Widgets and their position not saved with Plasma

I am using an external display from my laptop where I wish the widgets to be saved and preferably in the correct position. It appears sessions is where one is to look first. I’ve tried numerous configurations but this is the current version:

Any ideas?

1 Like

Select “Restore manually saved session” and click Apply.

Then position and set everything up how you like it.

When satisfied, go to your launcher, click on “Save Session”.

Then logout, and log back in.

1 Like

Sorry, but what launcher?

Whatever launcher you use to start applications or logout. Usually in the bottom-left corner of your panel.

1 Like

yes, I don’t see an option for saving a session. MMcK launcher

The default launcher (Application Launcher) has this option, when you click on the small “Leave” button.

As does the Legacy Launcher, when you go to the “Leave” tab.

1 Like

Found it. The windows are saved when saving the session and logging in-out, but the widgets are not. I can share a video if you want…

Yeah that would be interesting.

Video: Self-Destructing, Single-Use File Sharing

Same behavior when using the laptop as primary screen.

Vertical video gives me major anxiety and claustrophobia.

1 Like

Vertical video gives me major anxiety and claustrophobia.

:rofl: :rofl: now what do you think of the situation?

I couldn’t figure out what I was watching. :face_with_spiral_eyes:

Pull yourself together! It’s so obvious whats going on:

  1. show the session settings
  2. add the widget
  3. save session
  4. log out
  5. log in
  6. widget gone…

Did you try
“Save Session”
using
the default
launcher? It
might issue a
different
command for
the latest
KDE/Plasma
release.


If that still
doesn’t work,
try a new “test”
user, which
might provide
a hint that this
is due to a corrupt
or mis-formatted
config file for
your primary user
account.

Nice detail making it vertical :rofl:

Other than that. Very odd… my spare user worked. But now this user “works” but completely messes up the positions (external display)…

Another issue I am dealing with is that SDDM login only display on my external display (laptop display completely black upon boot, even if the external is not connected) despite it not being primary (anymore). The workaround is auto logging in or simply not logging out, not so great either option…

Very odd and unpredictable things going on…

One other idea. Can’t type in phone. When I get back home.

Since the “Save Session” seems to be working for the current user now, you can try to start “fresh” on your Display / Monitor settings.

Doing the following will require you to re-do your display settings, but hopefully end up with a better-lasting result.

  1. Log out of KDE

  2. Switch to TTY3 with CTRL + ALT + F3, and login as your user

  3. Stop the display manager service

sudo systemctl stop display-manager
  1. Rename the old config folder
mv ~/.local/share/kscreen ~/.local/share/kscreen.old
  1. Rebuild the KDE cache, and wait 10 seconds
kbuildsycoca5 --noincremental && sleep 10s
  1. Restart the display manager and login to KDE
sudo systemctl restart display-manager && exit

Now reconfigure your Display / Monitor settings, and see if that helps any.

Checking online it appears that this is the correct keybind. However it doesn’t work for me at any point; either now reading this or when having logged out ;/