Widevine brave not working anymore

Hey,
since a few months actually, I cannot play DRM protected content in Brave anymore. I am using the stable from official repo.
Even though I uninstalled, reinstalled or updated it, it does not work. Playing DRM protected content with Firefox works flawlessly.
Even Brave beta from official stable branch does not play DRM controlled media.
Any idea?
Best regards
beiju

For the easy part, did you enable it in the options: brave://settings/?search=DRM

Do you have a test page? This page works: Widevine DRM instantiation example

Yes, I unchecked, rechecked, restarted it several times. I even copied the widevide folder from firefox or from brave (from flathub, which works) to the folder. No change.
The video from your link does not play either.

Could you test with a new profile? Copying random stuff between browsers doesn’t seem to be the best of ideas.

Can you test other chromium based browsers like Chrome, Edge, Vivaldi, and Opera?

Indeed, it does not work with Vivaldi and Opera as well from official repos.
Need to test it with a new profile still. But I in the end, I want to fix it without switching to a new profile.

The new profile is just a test if it’s a setting, addon, or something old in your profile. If it works in a new profile, then you know at least Brave itself works and troubleshooting is easier.
If it doesn’t work in a new profile (which, I guess will be the case for you because Opera/Vivaldi also doesn’t work)

Hey, thanks for answering.
New tests:

  • Chrome from AUR does work
  • Brave from AUR does not work
  • Brave from Flatpak does work

New profile created, Brave does not even open there. I guess it is completely broken. I may need to remove everything Brave related, but if Vivaldi and so on do not work…
I could live with Brave from Flathub.
May be the problem, that I switched from Plasma to XFCE? And I even did not create a new user. But deleted all plasma related folders and files in my home folder…that caused perhaps a little harm as well.