Wi-Fi stopped working after update

I just updated Manjaro Sway on my Pinebook Pro and now I can’t see any wifi networks nor any bluetooth devices.

Checking the privacy switch, rebooting more than 4 times and systemctl restart NetworkManager did not help.

$ cat /var/log/pacman.log | grep -i "d systemd (\|ed linux\|mware\|twork\|dkms ins\|a-nm\|nm-c\|ufw\|dhc\|dns\|wpa\|vnc" | grep -v "head\|nvidia" 

[2022-10-22T18:34:05+0200] [ALPM] upgraded systemd (249.7-2 -> 251.6-2)
[2022-10-22T18:34:12+0200] [ALPM] upgraded glib-networking (1:2.70.1-1 -> 1:2.74.0-1)
[2022-10-22T18:34:20+0200] [ALPM] upgraded ap6256-firmware (2020.02-8 -> 2020.02-10)
[2022-10-22T18:35:46+0200] [ALPM] upgraded dhclient (4.4.2.P1-2 -> 4.4.3.P1-1)
[2022-10-22T18:35:52+0200] [ALPM] upgraded ldns (1.7.1-2 -> 1.8.3-1)
[2022-10-22T18:38:57+0200] [ALPM] upgraded linux (5.15.11-1 -> 6.0.2-3)
[2022-10-22T18:38:57+0200] [ALPM] installed linux-firmware-whence (20220913.f09bebf-1)
[2022-10-22T18:39:12+0200] [ALPM] upgraded linux-firmware (20211027.1d00989-1 -> 20220913.f09bebf-1)
[2022-10-22T18:39:41+0200] [ALPM] upgraded nm-connection-editor (1.24.0-1 -> 1.28.0-1)
[2022-10-22T18:39:42+0200] [ALPM] upgraded wpa_supplicant (2:2.9-8 -> 2:2.10-5)
[2022-10-22T18:39:44+0200] [ALPM] upgraded networkmanager (1.30.2-1 -> 1.40.0-1)
[2022-10-22T18:39:44+0200] [ALPM] upgraded network-manager-applet (1.24.0-1 -> 1.28.0-1)
[2022-10-22T18:39:46+0200] [ALPM] upgraded networkmanager-openconnect (1.2.7dev+65+gca4187c-1 -> 1.2.8-2)
[2022-10-22T18:39:47+0200] [ALPM] upgraded networkmanager-openvpn (1.8.16-1 -> 1.10.0-1)
[2022-10-22T18:40:51+0200] [ALPM] upgraded python-dnspython (1:2.1.0-1 -> 1:2.2.1-1)
[2022-10-22T18:43:11+0200] [ALPM] upgraded tigervnc (1.12.0-1 -> 1.12.0-3)
[2022-10-22T18:43:12+0200] [ALPM-SCRIPTLET] New version of U-Boot firmware can be flashed to your microSD card (mmcblk1)
[2022-10-22T18:45:05+0200] [ALPM] running 'networkmanager-connectivity.hook'...
$ dmesg | grep brcm

[    6.562594] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43456-sdio for chip BCM4345/9
[    6.565061] brcmfmac mmc0:0001:1: Direct firmware load for brcm/brcmfmac43456-sdio.pine64,pinebook-pro.bin failed with error -2
[    6.574316] usbcore: registered new interface driver brcmfmac
[    6.663762] ieee80211 phy0: brcmf_c_preinit_dcmds: Default MAC is used, replacing with random MAC to avoid conflicts
[    6.664063] ieee80211 phy0: brcmf_c_set_cur_etheraddr: Setting cur_etheraddr failed, -52
[    6.664069] ieee80211 phy0: brcmf_bus_started: failed: -52
[    6.664082] ieee80211 phy0: brcmf_attach: dongle is not responding: err=-52
[    6.731051] brcmfmac: brcmf_sdio_firmware_callback: brcmf_attach failed
[    7.241504] Bluetooth: hci0: BCM4345C5 'brcm/BCM4345C5.hcd' Patch

At this point I’m stuck… Luckily I am able to use internet through my phone.

Try a cold boot.

Wifi and Bluetooth is really flaky when doing reboots/warmboots.

Problem solved - you are my hero of the day! :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.