Why only 2 power modes by default

I am curious as to why out of the box, all the Linux kernels seem to offer only 2 power modes , either performance or power save.
When I go to configure TLP I am offered choices like " On demand" “Conservative " ect in TLP is says I must " disable my distributions governor”
I am somewhat a newbie so I am wondering if I should do so .
Becasue when I choose the default " power save " performance is mushy but My 6 core 12 thread 10600k will throttle down , if I choose the performance governor , all cpu’s stay at 4.1Ghz
seems like it would be better to run on sceduled or on demand governors On a muli-core cpu

Usually people that install Manjaro on Desktop PC will remove TLP, some others will prefer some other Power management - ArchWiki tools … As is, is more generally valid and working for different systems by default, and people can dive into personalized options.

2 Likes

Hi @brothergc,

I have absolutely no idea if I’, correct or not, if nobody corrects me on this, I’m going to assume I am. This is my understanding, based on your description I read just now:

CPUs, at least my Intel and I suspect most, if not all Intel CPUs, have 2 governors, Powersave and Performance. These are hardware-based, “built into” the CPUs. Hence, they are supported by default. I do not know if this is thee case for AMD CPUs.

Any other power saving modes, or governors, are software-based. Like the list provided by @bogdancovaciu. They limit thing based on a software analasys of what’s going on. Hence they take some CPU power. To do their thing.

I personally would like to keep it on Powersave, as I don’t play games a lot, if at all, but when I enable that governor, my PC becomes extremely sluggish and hard to work on. And I’ve also got a 6-core 12-thread machine, but it still happens. Just for startup, it more than doubles the time neccessary to start. So I switched it to performance, and it’s there for now. At until someone can give me better/different advice to try out.

You can check available governors:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

I have a Ryzen 5 3600 and powersave doesn’t really make the computer slow, it just forces a low frequency.

I think by default AMD uses schedutil, and performance will force max frequency all the time (not recommended unless in a game in my opinion). Here is the list of governors for my CPU:

conservative ondemand userspace powersave performance schedutil

Here is how I change governor:

sudo cpupower frequency-set -g GorvernorNameHere

My opinion as well.

Exactly the way I do it.

I think I got it sorted out buy just going with the default governor and adding some additional programs

ananicy-git is a big help note You will have to create a start up service see:

I also installed pstate-frequency and cpupower-gui
made cpupower a start up service
installed TLP GUI and configured all for Default AC mode

BIG help here thanks think I just stay with the default " power save" governor
Oh and I installed “Game mode” for steam BIG help running far cry

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.