Why is port 8080 not working?

hello everyone 8080 does not work here I was told that manyaro will block frequently used ports by looking for and sort of configured with
gufw then it worked fine but it doesn’t work, maybe it’s because of the uninstalled wifi
in the terminal I entered the command uvv defualt day incoming uvv defualt allov utgoing

A Manjaro system does not enable any services allowing external access to the system - this means no firewall is needed.

When you enable any service which exposes the system - you should setup some kind of security to protect your system.

If your system has enabled firewall - then ports are blocked.

You will have to configure the firewall to allow certain incoming traffic.

If you run a local development webserver - changing the firewall rules are not necessary.

But as there is two common firewall applications you should check which one is running

systemctl status firewalld ufw

What is your actual issue, precisely?

emm I use this port sometimes with py3. But I do not use firewalld and ufw. So what happen to you? what is the log or output?

No, it doesn’t.

It is important that you understand the theory. There are two kinds of ports: privileged and unprivileged. Privileged ports are the ports from 0 to 1023; those are the ports available to system services. The unprivileged ports are all the ports from 1024 on all the way up to 65536; those are the ports available to userspace software.

As @linux-aarhus said, by default Manjaro does not enable any services that listen on privileged ports, but that does not mean that those ports would be blocked.

What can and does often happen however is that internet providers block all ports below 1024 for domestic customers, so that those customers would not be able to run any internet-facing services on their computers, and that they would thus need to purchase a more expensive internet contract in order to be able to do that.

Now, that said, port 8080 is a userspace port — quite obviously, it sits above 1023 — and specifically, it is the port used by proxy server software, such as squid. So the question is: are you running or trying to run a proxy server on your own computer?


i work in intelleji idea and through postman I turn to my computer (server) writes that port 8080 is already in use but I only run one app. right now it works, when I switch to another wifi the router does not work

Unit firewalld.service could not be found.
● ufw.service - CLI Netfilter Manager
Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; vendor preset: disabled)
Active: active (exited) since Fri 2022-04-15 14:29:24 +05; 2h 50min ago
Main PID: 261 (code=exited, status=0/SUCCESS)
CPU: 54ms

is it possible to fix the error so that port 8080 works stably in all routers

I do not think this is an error about system. More like your software config in intelleji idea

1 Like

Please explain in simple words what your doing, which port on which computer you want to access from which (other?) computer?

This is very similar to how I use my system - I design and develop business software systems.

I run both server (windows vm) and client (Jetbrains Rider building a dotnet blazor wasm) locally and use postman for testing my api responses.

I cannot say what is your issue - you should not need to change any firewall rules unless you are accessing your development work from a client system outside your primary system e.g. your phone or your tablet.

  • ff you are at home
  • if you are on your local network
  • if you are behind a NAT router

If the above is all true - you can safely disable ufw.

I can guarantee - all unprivileged ports work without any hickups on Manjaro - questions like this is always caused by lack of knowledge - don’t worry - I learn something new every day.

When you ask such question - then you have very little knowledge of how it actually works - which in turn tells me you are very new at creating applications and webservices.

So here’s a brief lesson

If you are trying to access your development service from a third system - then you need to use the IP address or the hostname e.g.


And that may not be available due to your settings. When you start your service you need to specify it to run on because localhost:8080/ can only be reached on the machine it is running ontop of.

it works when I connect wifi router A, in another wifi router B it doesn’t always often throw such an error, in the Intelleji idea application I can change the port but I don’t want to work like in my

Are you trying to reach or is it some other address in the postman?

Also few more debugging tips:

  • what does curl -vvv http://the adress i use/ tell you?
  • what does nc myhostname 8080 tell you? Can you connect?
  • what about netstat -tlnp is anything listening on the port?
  • and sudo iptables-save ?