Why has "Caps_Lock" no corresponding keycodes?

Until yesterday(?) i could disable Caps_Lock key on my XFCE stable Manjaro but now thats isn’t working anymore!

I used ~/.xmodmaprc with

remove Lock = Caps_Lock
keycode 66 = BackSpace

But that now reults in an error:

$ xmodmap -verbose ~/.xmodmaprc
! /home/john1/.xmodmaprc:
! 1: remove Lock = Caps_Lock
xmodmap: /home/john1/.xmodmaprc:1: bad keysym in remove modifier list ‘Caps_Lock’, no corresponding keycodes
remove lock =
! 2: keycode 66 = BackSpace
keycode 0x42 = BackSpace
xmodmap: 1 error encountered, aborting.

What has changed since some days?
I think nothing but what is wrong with my ~/.xmodmaprc ?

Tipps are welcome
… and yes, i hate my Caps_Lock key :slight_smile:

More Info on my Manjaro:
Manjaro Log Helper tells

Kernel 5.8 is EOL. Have you updated your system recently and rebooted? I would try a different kernel to start with.

I reverted to kernel 5.8 because with kernel 5.9 i had lots of trouble: lost internet after reboot for example …

Just tried:

    Linux manjaro 5.9.11-3-MANJARO #1 SMP PREEMPT Sat Nov 28 09:08:57 UTC 2020 x86_64 GNU/Linux

That worked ok after first reboot but then produced known error.

I’ll now try to understand whats about localctl that was mentioned in archwiki …

In XFCE systemsettings i set:

That works, i don’t know why!

Hope that lasts forever!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.